Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Service, Recalls, Warranty & Maintenance

Service, Recalls, Warranty & Maintenance Valuable service and maintenance information. Also discussion which engine and transmission fluids you use.

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 03-08-2013, 03:11 AM   Thread Starter #1
Newbie
my6thgen.org Profile Info.
 
simi's Avatar
 
Join Date: Sep 2010
Official Member #: 748
Last Online: 05-30-2013 12:36 AM
Posts: 8

Reputation Level: 0
simi is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Had My Car For 100k+ Miles, Need Advise

Hows it going everyone, i've been lucky enough to own my 04 Maxima since it had 20k miles and now with it approaching 120k miles and 6 years later I want to get some preventative work done to keep it running smooth for as long as I can. Luckily it has NEVER given me any problems (until a couple weeks back) and hopefully it has a long life ahead of it too. Other than oil changes every 4-5k miles, a tranny flush I did at 80k miles and brake pad replacments, I havent done any other work to the car in about 4 years. Ive read up on the forums and saw that recommend work includes:

Spark Plug & Ignition Coil Replacment (I was also recommend wiring replacement)
Alternator & Power Steering Belt Replacment

My question is, what else should I get done and what is the approximate cost of the work i listed above and anything else thas needed? I just dont wanna get overcharged for work at local shops.

And my 2nd question: A weird problem has popped up in my car several weeks ago. I took my car for a 200 mile roadtrip to the mountains, it worked fine, no problems...but I get home,let it rest for about a hour....try to start it up and the gears start to "clunk" whenever I switch them, and the RPM wont go above 2500RPM no matter if I floor it. Really weird problem so I do several laps around my block, nothing changes, RPM wont go above 2500RPM, it just stays continuosly around that area. So i let it sit overnight, next morning - working perfectly fine no problem. I drive it daily for the next 2 weeks, no problems at all, and all of a sudden I get the RPM problem again while im driving on the freeway. I was going fine for a while but then the car seemed to slow down - I tried pressing harder on the acceleration, flooring it, no-go it just stays around 2500 RPM. I get home, let it rest for 2 hours and its back to normal. Its been about 2 weeks since it happened, no problems since then but I would like to get it figured it out before Im stranded anywhere, anybody got any ideas what could cause it? I took it a shop, no codes thrown out on the OBD scanner.

Thanks in advance!
simi is offline   Send a private message to simi Find more posts by simi Add simi to Your Friends list Reply With Quote top
Old 03-08-2013, 03:21 AM   #2
Senior Member
my6thgen.org Profile Info.
 
allblackmax607's Avatar
 
Join Date: Sep 2011
Official Member #: 3125
Last Online: 06-04-2013 03:35 PM
Location: Bing-a-ling
Posts: 536

Reputation Level: 9
allblackmax607 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Had my car for 100k+ miles, what work needs to be done & costs, also a weird prob

Hope you get that fixed man. Could be the tranny. Some more experienced members will be with you shortly im sure.
allblackmax607 is offline   Send a private message to allblackmax607 Find more posts by allblackmax607 Add allblackmax607 to Your Friends list Reply With Quote top
Old 03-08-2013, 08:02 AM   #3
Premier Member
my6thgen.org Profile Info.
 
PetitFrereMaxima's Avatar
 
Join Date: Jun 2010
Official Member #: 300
Last Online: 05-17-2019 04:59 PM
Posts: 1,031

Reputation Level: 22
PetitFrereMaxima will become famous soon enoughPetitFrereMaxima will become famous soon enough

Participation Level: 33%
Activity: 33% Activity: 33% Activity: 33%

My Awards:
Active Member  


/ Point Value: 5

Default Re: Had my car for 100k+ miles, what work needs to be done & costs, also a weird prob

Glad to know you have had your car since 20K and no problems for a while. Typically, most people sell their cars around 100K or 120K because from then on they are more prone to give you problems.

Most people know the scheduled maintenance and try to do as much as they can afford or deem necessary for their car. To know what needs to be done and at what time, stop by the dealership and take a RECOMMENDED maintenance schedule. Then decide what you can afford and what you would like to do according to your own personal priorities. To help you with some ideas, check out my thread below. You will see what I personally do for my car. Others do theirs differently. It is totally up to you what you wish to do for your car and sometimes, the main stumbling block is just the cost of parts or labor that discourages some people. And I don't blame them, costs can be overwhelming some time. I hope my thread can help you out.

Emile's PetitFrereMaxima

Feel free to PM me or ask your questions.

As for what your car is doing right now, I know I have read that somewhere on here. So, I know someone would chime in about your problem.
__________________
Click the image to open in full size.Click the image to open in full size.Click the image to open in full size.

My BUILD/MAINTENANCE thread. Aiming for 250K on odometer.
http://my6thgen.org/f13/emiles-petitfreremaxima-17985/ ... CATCH ME IF YOU CAN
https://www.clubarmada.com/forums/21...ton-tx-63.html... KING OF THE ROAD
Likes: (2)
allblackmax607 (03-08-2013), simi (03-10-2013)
PetitFrereMaxima is offline   Send a private message to PetitFrereMaxima Find more posts by PetitFrereMaxima Add PetitFrereMaxima to Your Friends list Reply With Quote top
Old 03-08-2013, 10:02 AM   #4
Official Member
my6thgen.org Profile Info.
 
fla_boi954's Avatar
 
Join Date: Sep 2012
Official Member #: 6166
Last Online: 12-04-2015 11:55 AM
Posts: 171

Reputation Level: 7
fla_boi954 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Had my car for 100k+ miles, what work needs to be done & costs, also a weird prob

Sounds like u have the infamous valve body problem your looking at around 1500 to fix
fla_boi954 is offline   Send a private message to fla_boi954 Find more posts by fla_boi954 Add fla_boi954 to Your Friends list Reply With Quote top
Old 03-08-2013, 10:10 AM   #5
Senior Member
my6thgen.org Profile Info.
 
allblackmax607's Avatar
 
Join Date: Sep 2011
Official Member #: 3125
Last Online: 06-04-2013 03:35 PM
Location: Bing-a-ling
Posts: 536

Reputation Level: 9
allblackmax607 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Had my car for 100k+ miles, what work needs to be done & costs, also a weird prob

@smittybizzle @BurntOrangeAppeal those 3 solenoids possibly??
allblackmax607 is offline   Send a private message to allblackmax607 Find more posts by allblackmax607 Add allblackmax607 to Your Friends list Reply With Quote top
Old 03-08-2013, 12:32 PM   #6
Official Member
my6thgen.org Profile Info.
 
Costee's Avatar
 
Join Date: Mar 2011
Official Member #: 2035
Last Online: 05-18-2019 02:53 PM
Location: Lagos, Nigeria
Posts: 307

Reputation Level: 10
Costee is on a distinguished road

Participation Level: 99%
Activity: 99% Activity: 99% Activity: 99%
Default Re: Had my car for 100k+ miles, what work needs to be done & costs, also a weird prob

Originally Posted by fla_boi954 View Post
Sounds like u have the infamous valve body problem your looking at around 1500 to fix
That does not seem like the valve body problem. I'd suggest the MAF or the Cam sensors.
Likes: (2)
allblackmax607 (03-08-2013), smittybizzle (03-11-2013)
Costee is offline   Send a private message to Costee Find more posts by Costee Add Costee to Your Friends list Reply With Quote top
Old 03-08-2013, 03:52 PM   #7
Official Member
my6thgen.org Profile Info.
 
Nick Fondz's Avatar
 
Join Date: Aug 2012
Official Member #: 6036
Last Online: 09-25-2014 03:17 PM
Location: North Jersey
Posts: 175

Reputation Level: 7
Nick Fondz is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Visit Nick Fondz's Twitter
Default Re: Had my car for 100k+ miles, what work needs to be done & costs, also a weird prob

Originally Posted by Costee View Post
That does not seem like the valve body problem. I'd suggest the MAF or the Cam sensors.
Sounds like your camshaft positioning sensor. I had the same thing happen to mine when I first got it. Not a crazy job

Comments
  
  Awesome help
__________________
Click the image to open in full size.
Likes: (2)
maxima31 (03-10-2013), simi (03-10-2013)
Nick Fondz is offline   Send a private message to Nick Fondz Find more posts by Nick Fondz Add Nick Fondz to Your Friends list Reply With Quote top
Old 03-10-2013, 02:59 PM   #8
Newbie
my6thgen.org Profile Info.
 
maxima31's Avatar
 
Join Date: Sep 2011
Official Member #: 3181
Last Online: 02-09-2016 02:30 PM
Posts: 59

Reputation Level: 8
maxima31 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Had My Car For 100k+ Miles, Need Advise

Could be the TCM???
maxima31 is offline   Send a private message to maxima31 Find more posts by maxima31 Add maxima31 to Your Friends list Reply With Quote top
Old 03-11-2013, 08:58 PM   #9
Reputable Member
my6thgen.org Profile Info.
 
smittybizzle's Avatar
 
Join Date: Jan 2011
Official Member #: 1598
Last Online: 03-01-2019 11:33 PM
Location: Baltimore,MD
Posts: 2,222

Reputation Level: 21
smittybizzle will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Had My Car For 100k+ Miles, Need Advise

I don't know?
smittybizzle is offline   Send a private message to smittybizzle Find more posts by smittybizzle Add smittybizzle to Your Friends list Reply With Quote top
Old 03-19-2013, 01:55 PM   #10
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Had My Car For 100k+ Miles, Need Advise

You Max is in limp mode. There is a lot probable causes. One of them is the MAF. Basically, if your MIL or CEL light has an open circuit with a malfunction present, where the ECM can NOT warn the driver then the ECM throws a LIMP mode by cutting off fuel supply past 2400 RPM.

You need to have it diagnosed and scanned properly. I would recommend paying a dealer for an hour or so to diagnose (dont let them make repairs yet unless its something Inexpensive) then we can help you a bit more as to the direction to take with the repairs.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
Likes: (1)
smittybizzle (03-19-2013)
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 05:15 PM.