Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions

Ask Your Technical & General Questions Ask your general and/or technical questions relating to any problem you're experiencing or troubleshooting.

View All Technical & General Questions

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 01-12-2013, 01:20 PM   Thread Starter #1
Newbie
my6thgen.org Profile Info.
 
02MaxSe's Avatar
 
Join Date: Jan 2013
Official Member #: 6959
Last Online: 01-16-2013 07:31 AM
Posts: 4

Reputation Level: 0
02MaxSe is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

As you see in title, when i start the car it sounds nasty and sometimes wants to stall, and im getting codes p0011, p0021, p1800 as of this morning 1/12/13. Common issue? and fixes?
02MaxSe is offline   Send a private message to 02MaxSe Find more posts by 02MaxSe Add 02MaxSe to Your Friends list Reply With Quote top
Old 01-12-2013, 01:24 PM   #2
Official Member
my6thgen.org Profile Info.
 
byrothapyro's Avatar
 
Join Date: Sep 2011
Official Member #: 3069
Last Online: 10-17-2018 10:00 PM
Posts: 115

Reputation Level: 10
byrothapyro is on a distinguished road

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

I have a similar problem here too.. :/

Few Complex Issues. Input/Advice Needed.

Please let us know if you figure it out!

Posted Via Tapatalk2
byrothapyro is offline   Send a private message to byrothapyro Find more posts by byrothapyro Add byrothapyro to Your Friends list Reply With Quote top
Old 01-12-2013, 02:43 PM   #3
Official Member
my6thgen.org Profile Info.
 
fla_boi954's Avatar
 
Join Date: Sep 2012
Official Member #: 6166
Last Online: 12-04-2015 11:55 AM
Posts: 171

Reputation Level: 7
fla_boi954 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stall And Codes P0011, P0021, P1800

I have to the same problems my car would also stall when driven too long I was told I need cam and crank sensors maybe u need the same
fla_boi954 is offline   Send a private message to fla_boi954 Find more posts by fla_boi954 Add fla_boi954 to Your Friends list Reply With Quote top
Old 01-12-2013, 02:59 PM   Thread Starter #4
Newbie
my6thgen.org Profile Info.
 
02MaxSe's Avatar
 
Join Date: Jan 2013
Official Member #: 6959
Last Online: 01-16-2013 07:31 AM
Posts: 4

Reputation Level: 0
02MaxSe is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stall And Codes P0011, P0021, P1800

i had this issue back in 09 and replaced the cam and crank sensors...do they go bad that fast? i read some where else it could be dirt/grime build up on the sensors and to take them out and clean them off. I will try that and let everyone know, but i still dont know what the P1800 code is.

---------- Post added at 01:59 PM ---------- Previous post was at 01:58 PM ----------

oh and the cam/crank sensors are sooo easy to replace, if you have a manual you can locate and replace your self, no need to a mechanic to charge all the money for labor for something that will take you a half hour yourself tops
02MaxSe is offline   Send a private message to 02MaxSe Find more posts by 02MaxSe Add 02MaxSe to Your Friends list Reply With Quote top
Old 01-12-2013, 09:34 PM   #5
Official Member
my6thgen.org Profile Info.
 
fla_boi954's Avatar
 
Join Date: Sep 2012
Official Member #: 6166
Last Online: 12-04-2015 11:55 AM
Posts: 171

Reputation Level: 7
fla_boi954 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stall And Codes P0011, P0021, P1800

Well in my case my mechanic told me I had a leak that dripped on the sensor which caused them to go bad.. there's a thread somewhere on this site that discusses engine light codes maybe u can locate yours there
fla_boi954 is offline   Send a private message to fla_boi954 Find more posts by fla_boi954 Add fla_boi954 to Your Friends list Reply With Quote top
Old 01-13-2013, 12:20 AM   #6
Official Member
my6thgen.org Profile Info.
 
byrothapyro's Avatar
 
Join Date: Sep 2011
Official Member #: 3069
Last Online: 10-17-2018 10:00 PM
Posts: 115

Reputation Level: 10
byrothapyro is on a distinguished road

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

Check out my thread I posted above. Not trying to jack here, but I just replaced all three of those sensors. No luck..
P1800 is VIAS solenoid open circuit.

Posted Via Tapatalk2
byrothapyro is offline   Send a private message to byrothapyro Find more posts by byrothapyro Add byrothapyro to Your Friends list Reply With Quote top
Old 01-13-2013, 04:58 PM   #7
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

P0011, P0012 are codes relating to Intake Variable timing control Both Bank 1 and 2.

Make sure your oil level is up to proper mark.
Most common fix would be cam and Crank position sensors in your case. Makes sure you buy OEM Nissan sensors.
If this these 2 codes were combined with P1111 or P1136 (which they are not)Then IVT solenoids would have to be diagnosed as well.

Dont worry about the P1800 for now as chances are its triggered do to incorrect Intake valve timing input into ECM.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 01-15-2013, 08:14 AM   Thread Starter #8
Newbie
my6thgen.org Profile Info.
 
02MaxSe's Avatar
 
Join Date: Jan 2013
Official Member #: 6959
Last Online: 01-16-2013 07:31 AM
Posts: 4

Reputation Level: 0
02MaxSe is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

Burnt, thanks for the info...and its funny i am past due on my inspection cause of these damn codes coming on, and theres been lots of cops hanging out on highway ramps checking and Ive been avoiding certain roads cause this.

Do you think taking out the two sensors and cleaning them off and what not may help, like i said they are only a few years old to have gone bad so soon. And when i originally replaced them I was having that stall out/lack of power. This time around she drives fine, no issues, no lack of power, nothing.
02MaxSe is offline   Send a private message to 02MaxSe Find more posts by 02MaxSe Add 02MaxSe to Your Friends list Reply With Quote top
Old 01-15-2013, 10:07 AM   #9
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

Originally Posted by 02MaxSe View Post
Burnt, thanks for the info...and its funny i am past due on my inspection cause of these damn codes coming on, and theres been lots of cops hanging out on highway ramps checking and Ive been avoiding certain roads cause this.

Do you think taking out the two sensors and cleaning them off and what not may help, like i said they are only a few years old to have gone bad so soon. And when i originally replaced them I was having that stall out/lack of power. This time around she drives fine, no issues, no lack of power, nothing.
I would just change oil first. As far as sensors go you can clean them if you like. I doubt Its going to do anything for you. I would just replace the CAM sensors with OEM NIssan sensors.
Oh, and 2 year life span out of sensors that are probably made offshore is GREAT. Remember, sensors go, they are just sensors. Makes sure that the wiring is intact and that connector pins are not damaged also.
You should ask a dodge neon, Chrysler sebring and intrepid owners how the life time of their cam/crank sensor is. I change those ALL the time. They go out like a light bulb.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-

Last edited by BurntOrangeAppeal; 01-15-2013 at 12:23 PM.
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 01-15-2013, 05:33 PM   Thread Starter #10
Newbie
my6thgen.org Profile Info.
 
02MaxSe's Avatar
 
Join Date: Jan 2013
Official Member #: 6959
Last Online: 01-16-2013 07:31 AM
Posts: 4

Reputation Level: 0
02MaxSe is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

I actually changed the oil and filter on sunday and changed pcv valve cause i never changed that and its pennies so figured why not. When i change my oil i usually put 4 1/4 quarts in.

This morning i reset the codes, added more oil so im at about 4 3/4 quarts of oil in my car now (read up on that amount for maximas and this engine), and drove about 27 miles and the light came back on, but this time ONLY for P0021 and P0021 pending.

Oh and this afternoon when i started the car that rough sounding start didnt happen.

02MaxSe is offline   Send a private message to 02MaxSe Find more posts by 02MaxSe Add 02MaxSe to Your Friends list Reply With Quote top
Old 01-15-2013, 09:05 PM   #11
Newbie
my6thgen.org Profile Info.
 
bhp4202's Avatar
 
Join Date: Sep 2010
Official Member #: 747
Last Online: 07-31-2018 02:48 PM
Location: Syracuse, NY
Posts: 95

Reputation Level: 9
bhp4202 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Rough Start, Sometimes Stalls And Codes P0011, P0021, P1800

i just had that p0011 code last week but no light on and i've so far changed the oil and just have to wait and see if it comes back.
__________________
04 SE....Injen CAI....Jet MAF....Racingline Y-Pipe.... Ebay Cat-Back Exhaust....NWP BOP....NWP Spacers....
bhp4202 is offline   Send a private message to bhp4202 Find more posts by bhp4202 Add bhp4202 to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 04:30 PM.