Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Suspension, Handling & Brakes

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 05-31-2013, 05:20 PM   Thread Starter #1
Glendales Official 6th Gen
my6thgen.org Profile Info.
 
Kenny's Avatar
 
Join Date: Jul 2011
Official Member #: 2651
Last Online: 03-09-2016 03:59 AM
Location: Southern California
Posts: 5,356

Reputation Level: 35
Kenny has a spectacular aura aboutKenny has a spectacular aura about

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%

My Awards:
Supporting Family Member  


/ Point Value: 10

Active Member  


/ Point Value: 5

Most Valuable Poster (MVP)  


/ Point Value: 10

Visit Kenny's PS3 Profile Visit Kenny's Xbox Gamercard
Default Need Help With Wheel/Speed Sensor

What's up guys so I replaced my rear abs wheel speed sensor to a new one from the dealer and my abs light still comes on. Do I have to drive it for a while so it can go off or what can I do?
__________________
Click the image to open in full size.


Follow Me On Instagram/Twitter:@0mg350z
Kenny is offline   Send a private message to Kenny Find more posts by Kenny Add Kenny to Your Friends list Reply With Quote top
Old 06-01-2013, 01:33 AM   #2
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by Kenny View Post
What's up guys so I replaced my rear abs wheel speed sensor to a new one from the dealer and my abs light still comes on. Do I have to drive it for a while so it can go off or what can I do?
Kenny, you should be good imediately. No need to drive it for x amount of miles
How did you know which sensor to replace? Was it a specific code?

You know that different sidewall profiles can and sometimes will trigger ABS. You are staggered....

I would run a live data diagnostic to see how your sensors are reading and what the ABS module is communicating through OBDII.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
Likes: (1)
Costee (06-01-2013)
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 06-01-2013, 01:36 AM   Thread Starter #3
Glendales Official 6th Gen
my6thgen.org Profile Info.
 
Kenny's Avatar
 
Join Date: Jul 2011
Official Member #: 2651
Last Online: 03-09-2016 03:59 AM
Location: Southern California
Posts: 5,356

Reputation Level: 35
Kenny has a spectacular aura aboutKenny has a spectacular aura about

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%

My Awards:
Supporting Family Member  


/ Point Value: 10

Active Member  


/ Point Value: 5

Most Valuable Poster (MVP)  


/ Point Value: 10

Visit Kenny's PS3 Profile Visit Kenny's Xbox Gamercard
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by BurntOrangeAppeal View Post
Kenny, you should be good imediately. No need to drive it for x amount of miles
How did you know which sensor to replace? Was it a specific code?

You know that different sidewall profiles can and sometimes will trigger ABS. You are staggered....

I would run a live data diagnostic to see how your sensors are reading and what the ABS module is communicating through OBDII.
I went to the mechanic and they told me which to replace (I even googled the cel). I had the abs light on even before I went staggered so now I don't know what to do
__________________
Click the image to open in full size.


Follow Me On Instagram/Twitter:@0mg350z

Last edited by Kenny; 06-01-2013 at 01:42 AM.
Kenny is offline   Send a private message to Kenny Find more posts by Kenny Add Kenny to Your Friends list Reply With Quote top
Old 06-01-2013, 01:49 AM   #4
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by Kenny View Post
I went to the mechanic and they told me which to replace (I even googled the cel). I had the abs light on even before I went staggered so now I don't know what to do
I see.
Yeah, you need to go back and run diagnostics. It might be a input problem ( wire corroded) maybe since you are low you hit something)... between the sensor and the Abs module not the sensor itself.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 06-01-2013, 02:02 AM   Thread Starter #5
Glendales Official 6th Gen
my6thgen.org Profile Info.
 
Kenny's Avatar
 
Join Date: Jul 2011
Official Member #: 2651
Last Online: 03-09-2016 03:59 AM
Location: Southern California
Posts: 5,356

Reputation Level: 35
Kenny has a spectacular aura aboutKenny has a spectacular aura about

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%

My Awards:
Supporting Family Member  


/ Point Value: 10

Active Member  


/ Point Value: 5

Most Valuable Poster (MVP)  


/ Point Value: 10

Visit Kenny's PS3 Profile Visit Kenny's Xbox Gamercard
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by BurntOrangeAppeal View Post
I see.
Yeah, you need to go back and run diagnostics. It might be a input problem ( wire corroded) maybe since you are low you hit something)... between the sensor and the Abs module not the sensor itself.
Like I said I had this problem before I was stanced out at first I thought it was the wheel bearings but it wasnt that either then I tried the sensor and wasnt this how would I run diagnostics, taking it to a mechanic?
__________________
Click the image to open in full size.


Follow Me On Instagram/Twitter:@0mg350z
Kenny is offline   Send a private message to Kenny Find more posts by Kenny Add Kenny to Your Friends list Reply With Quote top
Old 06-01-2013, 02:20 AM   #6
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by Kenny View Post
Like I said I had this problem before I was stanced out at first I thought it was the wheel bearings but it wasnt that either then I tried the sensor and wasnt this how would I run diagnostics, taking it to a mechanic?
Yes. Unless you have access to a diagnostic scan tools that mechanics use that has those capabilities.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 06-01-2013, 02:03 PM   #7
Official Member
my6thgen.org Profile Info.
 
Costee's Avatar
 
Join Date: Mar 2011
Official Member #: 2035
Last Online: Yesterday 05:20 AM
Location: Lagos, Nigeria
Posts: 307

Reputation Level: 10
Costee is on a distinguished road

Participation Level: 99%
Activity: 99% Activity: 99% Activity: 99%
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by Kenny View Post
I went to the mechanic and they told me which to replace (I even googled the cel). I had the abs light on even before I went staggered so now I don't know what to do
What was the code you googled?
Costee is online now   Send a private message to Costee Find more posts by Costee Add Costee to Your Friends list Reply With Quote top
Old 06-01-2013, 05:01 PM   Thread Starter #8
Glendales Official 6th Gen
my6thgen.org Profile Info.
 
Kenny's Avatar
 
Join Date: Jul 2011
Official Member #: 2651
Last Online: 03-09-2016 03:59 AM
Location: Southern California
Posts: 5,356

Reputation Level: 35
Kenny has a spectacular aura aboutKenny has a spectacular aura about

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%

My Awards:
Supporting Family Member  


/ Point Value: 10

Active Member  


/ Point Value: 5

Most Valuable Poster (MVP)  


/ Point Value: 10

Visit Kenny's PS3 Profile Visit Kenny's Xbox Gamercard
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by Costee View Post
What was the code you googled?
To be honest I don't remember
__________________
Click the image to open in full size.


Follow Me On Instagram/Twitter:@0mg350z
Kenny is offline   Send a private message to Kenny Find more posts by Kenny Add Kenny to Your Friends list Reply With Quote top
Old 06-01-2013, 09:01 PM   #9
Newbie
my6thgen.org Profile Info.
 
b15son's Avatar
 
Join Date: Apr 2012
Official Member #: 5073
Last Online: 10-27-2015 04:34 PM
Posts: 30

Reputation Level: 0
b15son is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Need Help With Wheel/Speed Sensor

I had one where i had a wheel speed sensor code for the rear hub, customer replaced wheel speed sensor and it didnt fix it. I went in there and found that the hub assembly was a non abs one that had no pickup magnet internally. The car had been wrecked and it had junk yard parts and one of the hubs that were replaced were incorrect off a non abs vehicle therefore the new wheel speed sensor never picked up any wheel speed data off the magnet causing the code to keep being throw. Just something you might want to check out
Likes: (1)
BurntOrangeAppeal (06-01-2013)
b15son is offline   Send a private message to b15son Find more posts by b15son Add b15son to Your Friends list Reply With Quote top
Old 06-01-2013, 09:07 PM   Thread Starter #10
Glendales Official 6th Gen
my6thgen.org Profile Info.
 
Kenny's Avatar
 
Join Date: Jul 2011
Official Member #: 2651
Last Online: 03-09-2016 03:59 AM
Location: Southern California
Posts: 5,356

Reputation Level: 35
Kenny has a spectacular aura aboutKenny has a spectacular aura about

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%

My Awards:
Supporting Family Member  


/ Point Value: 10

Active Member  


/ Point Value: 5

Most Valuable Poster (MVP)  


/ Point Value: 10

Visit Kenny's PS3 Profile Visit Kenny's Xbox Gamercard
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by b15son View Post
I had one where i had a wheel speed sensor code for the rear hub, customer replaced wheel speed sensor and it didnt fix it. I went in there and found that the hub assembly was a non abs one that had no pickup magnet internally. The car had been wrecked and it had junk yard parts and one of the hubs that were replaced were incorrect off a non abs vehicle therefore the new wheel speed sensor never picked up any wheel speed data off the magnet causing the code to keep being throw. Just something you might want to check out
Hmmm that's something I'm going to need to check out, sounds very convincing but my car has never been in a wreck maybe the last owner put non abs hubs?
__________________
Click the image to open in full size.


Follow Me On Instagram/Twitter:@0mg350z
Kenny is offline   Send a private message to Kenny Find more posts by Kenny Add Kenny to Your Friends list Reply With Quote top
Old 06-01-2013, 09:40 PM   #11
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by Kenny View Post
Hmmm that's something I'm going to need to check out, sounds very convincing but my car has never been in a wreck maybe the last owner put non abs hubs?
Didnt you post pictures of you replacing rear hubs?
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 06-01-2013, 09:41 PM   #12
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 33
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by b15son View Post
I had one where i had a wheel speed sensor code for the rear hub, customer replaced wheel speed sensor and it didnt fix it. I went in there and found that the hub assembly was a non abs one that had no pickup magnet internally. The car had been wrecked and it had junk yard parts and one of the hubs that were replaced were incorrect off a non abs vehicle therefore the new wheel speed sensor never picked up any wheel speed data off the magnet causing the code to keep being throw. Just something you might want to check out
Ive ran into the same issue on a customers altima and so did another tech I know. Quite common issue as people prefer buying the cheaper non ABS hub...
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 06-02-2013, 04:11 AM   Thread Starter #13
Glendales Official 6th Gen
my6thgen.org Profile Info.
 
Kenny's Avatar
 
Join Date: Jul 2011
Official Member #: 2651
Last Online: 03-09-2016 03:59 AM
Location: Southern California
Posts: 5,356

Reputation Level: 35
Kenny has a spectacular aura aboutKenny has a spectacular aura about

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%

My Awards:
Supporting Family Member  


/ Point Value: 10

Active Member  


/ Point Value: 5

Most Valuable Poster (MVP)  


/ Point Value: 10

Visit Kenny's PS3 Profile Visit Kenny's Xbox Gamercard
Default Re: Need Help With Wheel/Speed Sensor

Originally Posted by BurntOrangeAppeal View Post
Ive ran into the same issue on a customers altima and so did another tech I know. Quite common issue as people prefer buying the cheaper non ABS hub...
When I bought the hubs they were abs though for some reason I was thinking of the rotors when you guys said hub lol
__________________
Click the image to open in full size.


Follow Me On Instagram/Twitter:@0mg350z
Likes: (1)
BurntOrangeAppeal (06-02-2013)
Kenny is offline   Send a private message to Kenny Find more posts by Kenny Add Kenny to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 10:53 AM.