Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Intakes, Headers & Exhaust

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 09-21-2012, 07:27 PM   Thread Starter #1
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default P0420 After HFPC Installed

I actually asked about this a while back but never got around to fixing it. Heres the link:

P0420 Code With New HFPC

Well anyways I really want to go ahead and put in the time and labor to fix this myself. I did replace the O2 sensor at the top of the rear pre-cat but did not replace the bottom O2 sensor of the rear pre-cat. I know that could be the issue but I really hate to spend over $150 and still have this code after words.

What do you guys think about replacing that bottom one? Has anyone seen this go away after replacing that?

Another thing, Im kind of leaning towards using the O2 simulators and just bypassing this whole issue but do not know if this will work for this code.

Has anyone used the O2 simulator and got rid of this P0420 code? Also lets say that rear O2 sensor is bad, the O2 simulator will just bypass it anyway right?
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 09-21-2012, 11:00 PM   #2
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 34
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Originally Posted by Stack View Post
I actually asked about this a while back but never got around to fixing it. Heres the link:

P0420 Code With New HFPC

Well anyways I really want to go ahead and put in the time and labor to fix this myself. I did replace the O2 sensor at the top of the rear pre-cat but did not replace the bottom O2 sensor of the rear pre-cat. I know that could be the issue but I really hate to spend over $150 and still have this code after words.

What do you guys think about replacing that bottom one? Has anyone seen this go away after replacing that?

Another thing, Im kind of leaning towards using the O2 simulators and just bypassing this whole issue but do not know if this will work for this code.

Has anyone used the O2 simulator and got rid of this P0420 code? Also lets say that rear O2 sensor is bad, the O2 simulator will just bypass it anyway right?
No need to use a simulator. You need to replace the downstream sensor(post cat) TRUST ME.
Shop around. They are not 150 bucks.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
Likes: (1)
RAZ76 (09-24-2012)
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 09-24-2012, 04:59 AM   Thread Starter #3
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Alright if your that sure I'll give that a shot since I know that was the only thing left but I sure hope that light doesn't come back on after I spent the money on the O2 sensor.
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 09-24-2012, 07:29 AM   #4
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 34
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

You will be glad you did. :thumbup:
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 09-24-2012, 09:51 AM   #5
Premier Member
my6thgen.org Profile Info.
 
silvermax06's Avatar
 
Join Date: May 2011
Official Member #: 2470
Last Online: 06-03-2018 02:53 PM
Location: Virginia
Posts: 1,173

Reputation Level: 11
silvermax06 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Didn't think the HFPC's were suppose to throw a code......
silvermax06 is offline   Send a private message to silvermax06 Find more posts by silvermax06 Add silvermax06 to Your Friends list Reply With Quote top
Old 09-24-2012, 09:53 AM   #6
Premier Member
my6thgen.org Profile Info.
 
silvermax06's Avatar
 
Join Date: May 2011
Official Member #: 2470
Last Online: 06-03-2018 02:53 PM
Location: Virginia
Posts: 1,173

Reputation Level: 11
silvermax06 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

When i do decide to get them i am gonna buy new sensors for them to. Don't want to run risk of trying to get the old one's off an damaging them...
silvermax06 is offline   Send a private message to silvermax06 Find more posts by silvermax06 Add silvermax06 to Your Friends list Reply With Quote top
Old 09-24-2012, 11:51 PM   Thread Starter #7
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Originally Posted by silvermax06 View Post
Didn't think the HFPC's were suppose to throw a code......
Well if I replace that 2nd O2 sensor and the code goes away, this will still be true. I will try to replace this as soon as possible and let you guys know.
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 09-25-2012, 12:01 AM   #8
Moderator
Flipadelphia
my6thgen.org Profile Info.
 
06BlckMax's Avatar
 
Join Date: Sep 2010
Official Member #: 662
Last Online: 07-14-2019 10:40 PM
Location: IG: 06BlckMax
Posts: 6,827

Reputation Level: 56
06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Visit 06BlckMax's PS3 Profile
Default Re: P0420 After HFPC Installed

I have the same code with the HFPC been rocking it for year +
__________________
Click the image to open in full size.

------See How It Was Built------
06BlckMax is offline   Send a private message to 06BlckMax Find more posts by 06BlckMax Add 06BlckMax to Your Friends list Reply With Quote top
Old 09-25-2012, 12:09 AM   #9
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 34
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Originally Posted by 06BlckMax View Post
I have the same code with the HFPC been rocking it for year +
Why? You could easily get rid of that annoying light.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
Likes: (1)
KZ 259 (10-25-2012)
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 09-25-2012, 12:10 AM   Thread Starter #10
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Originally Posted by 06BlckMax View Post
I have the same code with the HFPC been rocking it for year +
Its been over a year for me too.

Did you replace any of the O2 sensors on your car?
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 09-25-2012, 12:14 AM   #11
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 34
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Originally Posted by Stack View Post
Its been over a year for me too.

Did you replace any of the O2 sensors on your car?
Id bet money, the answer will be "no"
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 09-25-2012, 12:15 AM   #12
Moderator
Flipadelphia
my6thgen.org Profile Info.
 
06BlckMax's Avatar
 
Join Date: Sep 2010
Official Member #: 662
Last Online: 07-14-2019 10:40 PM
Location: IG: 06BlckMax
Posts: 6,827

Reputation Level: 56
06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Visit 06BlckMax's PS3 Profile
Default Re: P0420 After HFPC Installed

Originally Posted by BurntOrangeAppeal View Post
Why? You could easily get rid of that annoying light.
dont notice any difference in how the car performs

If the sensors were cheaper I would do it or if it guaranteed to fix it
__________________
Click the image to open in full size.

------See How It Was Built------
06BlckMax is offline   Send a private message to 06BlckMax Find more posts by 06BlckMax Add 06BlckMax to Your Friends list Reply With Quote top
Old 09-25-2012, 12:17 AM   #13
Moderator
Flipadelphia
my6thgen.org Profile Info.
 
06BlckMax's Avatar
 
Join Date: Sep 2010
Official Member #: 662
Last Online: 07-14-2019 10:40 PM
Location: IG: 06BlckMax
Posts: 6,827

Reputation Level: 56
06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Visit 06BlckMax's PS3 Profile
Default Re: P0420 After HFPC Installed

Originally Posted by Stack View Post
Its been over a year for me too.

Did you replace any of the O2 sensors on your car?
No, sensors are expensive, dont know if it will actually fix it, and its a pain in the ass to get the sensor out
__________________
Click the image to open in full size.

------See How It Was Built------
06BlckMax is offline   Send a private message to 06BlckMax Find more posts by 06BlckMax Add 06BlckMax to Your Friends list Reply With Quote top
Old 09-25-2012, 12:54 AM   Thread Starter #14
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Bosch 15521 - Oxygen Sensor | O'Reilly Auto Parts

This is the sensor I need right? I did find it on Ebay for 95 if it is
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 09-25-2012, 10:19 AM   #15
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 34
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Originally Posted by Stack View Post
Bosch 15521 - Oxygen Sensor | O'Reilly Auto Parts

This is the sensor I need right? I did find it on Ebay for 95 if it is
:thumbup:
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 09-25-2012, 05:15 PM   #16
Premier Member
my6thgen.org Profile Info.
 
PetitFrereMaxima's Avatar
 
Join Date: Jun 2010
Official Member #: 300
Last Online: 06-18-2019 01:52 PM
Posts: 1,032

Reputation Level: 23
PetitFrereMaxima will become famous soon enoughPetitFrereMaxima will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Default Re: P0420 After HFPC Installed

I stubble across this thread today when my service engine soon light just came up too this morning. This sucks!!! The code that came up is P0420 like you guys. Not only that, but when I am on the gas and doing about 40mph or so and let off the gas, the car suddenly jerks a little and car feels as if it was a manual transmission down shifting.

Will replacing this O2 sensor fix this problem? I hope I am not jacking this thread. I just have the same code with a slight variation on how the car feels when I let go the gas pedal.
__________________
Click the image to open in full size.Click the image to open in full size.Click the image to open in full size.

My BUILD/MAINTENANCE thread. Aiming for 250K on odometer.
http://my6thgen.org/f13/emiles-petitfreremaxima-17985/ ... CATCH ME IF YOU CAN
https://www.clubarmada.com/forums/21...ton-tx-63.html... KING OF THE ROAD
PetitFrereMaxima is offline   Send a private message to PetitFrereMaxima Find more posts by PetitFrereMaxima Add PetitFrereMaxima to Your Friends list Reply With Quote top
Old 09-25-2012, 05:24 PM   #17
Moderator
Flipadelphia
my6thgen.org Profile Info.
 
06BlckMax's Avatar
 
Join Date: Sep 2010
Official Member #: 662
Last Online: 07-14-2019 10:40 PM
Location: IG: 06BlckMax
Posts: 6,827

Reputation Level: 56
06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Visit 06BlckMax's PS3 Profile
Default Re: P0420 After HFPC Installed

Originally Posted by PetitFrereMaxima View Post
I stubble across this thread today when my service engine soon light just came up too this morning. This sucks!!! The code that came up is P0420 like you guys. Not only that, but when I am on the gas and doing about 40mph or so and let off the gas, the car suddenly jerks a little and car feels as if it was a manual transmission down shifting.

Will replacing this O2 sensor fix this problem? I hope I am not jacking this thread. I just have the same code with a slight variation on how the car feels when I let go the gas pedal.
Not jacking at all I would like to hear everyones experience with p0420
__________________
Click the image to open in full size.

------See How It Was Built------
06BlckMax is offline   Send a private message to 06BlckMax Find more posts by 06BlckMax Add 06BlckMax to Your Friends list Reply With Quote top
Old 09-25-2012, 05:28 PM   #18
Premier Member
my6thgen.org Profile Info.
 
PetitFrereMaxima's Avatar
 
Join Date: Jun 2010
Official Member #: 300
Last Online: 06-18-2019 01:52 PM
Posts: 1,032

Reputation Level: 23
PetitFrereMaxima will become famous soon enoughPetitFrereMaxima will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Default Re: P0420 After HFPC Installed

Originally Posted by 06BlckMax View Post
Not jacking at all I would like to hear everyones experience with p0420
Thanks.

SO, what did you do about yours? Got it fixed?
__________________
Click the image to open in full size.Click the image to open in full size.Click the image to open in full size.

My BUILD/MAINTENANCE thread. Aiming for 250K on odometer.
http://my6thgen.org/f13/emiles-petitfreremaxima-17985/ ... CATCH ME IF YOU CAN
https://www.clubarmada.com/forums/21...ton-tx-63.html... KING OF THE ROAD
PetitFrereMaxima is offline   Send a private message to PetitFrereMaxima Find more posts by PetitFrereMaxima Add PetitFrereMaxima to Your Friends list Reply With Quote top
Old 09-25-2012, 05:29 PM   #19
Moderator
Flipadelphia
my6thgen.org Profile Info.
 
06BlckMax's Avatar
 
Join Date: Sep 2010
Official Member #: 662
Last Online: 07-14-2019 10:40 PM
Location: IG: 06BlckMax
Posts: 6,827

Reputation Level: 56
06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough06BlckMax is a jewel in the rough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Visit 06BlckMax's PS3 Profile
Default Re: P0420 After HFPC Installed

Originally Posted by PetitFrereMaxima View Post
Thanks.

SO, what did you do about yours? Got it fixed?
Nope just been driving with it, dont notice any difference
__________________
Click the image to open in full size.

------See How It Was Built------
06BlckMax is offline   Send a private message to 06BlckMax Find more posts by 06BlckMax Add 06BlckMax to Your Friends list Reply With Quote top
Old 09-25-2012, 05:34 PM   #20
Premier Member
my6thgen.org Profile Info.
 
PetitFrereMaxima's Avatar
 
Join Date: Jun 2010
Official Member #: 300
Last Online: 06-18-2019 01:52 PM
Posts: 1,032

Reputation Level: 23
PetitFrereMaxima will become famous soon enoughPetitFrereMaxima will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Default Re: P0420 After HFPC Installed

Originally Posted by 06BlckMax View Post
Nope just been driving with it, dont notice any difference
I notice a difference at about 40mph when I let go the gas pedal, the car "down-shifts" as if it is a manual transmission. I hate it. But I need to get this fixed.
__________________
Click the image to open in full size.Click the image to open in full size.Click the image to open in full size.

My BUILD/MAINTENANCE thread. Aiming for 250K on odometer.
http://my6thgen.org/f13/emiles-petitfreremaxima-17985/ ... CATCH ME IF YOU CAN
https://www.clubarmada.com/forums/21...ton-tx-63.html... KING OF THE ROAD
PetitFrereMaxima is offline   Send a private message to PetitFrereMaxima Find more posts by PetitFrereMaxima Add PetitFrereMaxima to Your Friends list Reply With Quote top
Old 09-25-2012, 07:03 PM   Thread Starter #21
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Originally Posted by PetitFrereMaxima View Post
I stubble across this thread today when my service engine soon light just came up too this morning. This sucks!!! The code that came up is P0420 like you guys. Not only that, but when I am on the gas and doing about 40mph or so and let off the gas, the car suddenly jerks a little and car feels as if it was a manual transmission down shifting.

Will replacing this O2 sensor fix this problem? I hope I am not jacking this thread. I just have the same code with a slight variation on how the car feels when I let go the gas pedal.
If you have the HFPC and this code came on after you installed them, then yes hopefully when you replace those O2 sensors the light should go off. But Im not going to be 100% sure until I do it.

As for the jerk, I also have something similar to that but Im pretty sure its my tranny mount or motor mount/s. Not sure if its the same type of jerk as you tho.
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 09-25-2012, 07:06 PM   #22
Premier Member
my6thgen.org Profile Info.
 
PetitFrereMaxima's Avatar
 
Join Date: Jun 2010
Official Member #: 300
Last Online: 06-18-2019 01:52 PM
Posts: 1,032

Reputation Level: 23
PetitFrereMaxima will become famous soon enoughPetitFrereMaxima will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Default Re: P0420 After HFPC Installed

Originally Posted by Stack View Post
If you have the HFPC and this code came on after you installed them, then yes hopefully when you replace those O2 sensors the light should go off. But Im not going to be 100% sure until I do it.

As for the jerk, I also have something similar to that but Im pretty sure its my tranny mount or motor mount/s. Not sure if its the same type of jerk as you tho.
Thanks for your response. I am all stock. I don't have any HFPC. But I guess I should start looking for one, lol.

As for the jerking, I am reading all over the internet and it says abot same thing as what you are saying: change motor mounts. I see these costing me money. This is crazy!
__________________
Click the image to open in full size.Click the image to open in full size.Click the image to open in full size.

My BUILD/MAINTENANCE thread. Aiming for 250K on odometer.
http://my6thgen.org/f13/emiles-petitfreremaxima-17985/ ... CATCH ME IF YOU CAN
https://www.clubarmada.com/forums/21...ton-tx-63.html... KING OF THE ROAD
PetitFrereMaxima is offline   Send a private message to PetitFrereMaxima Find more posts by PetitFrereMaxima Add PetitFrereMaxima to Your Friends list Reply With Quote top
Old 10-17-2012, 04:31 PM   Thread Starter #23
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Turns out the 15521 is the bottom O2 sensor for the front pre-cat. The 15525 is the bottom O2 sensor for the rear precat. I guess its backwards in the diagram but i did order the correct sensor already.

I shouldnt worry about the front precat sensor right?

Also is it possible to remove the bottom sensor of the rear precat without removing it? Seemed like a tight fit down there not much room to turn a ratchet or breaker bar
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 10-17-2012, 04:38 PM   Thread Starter #24
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

^^^^

Last edited by Stack; 10-17-2012 at 04:39 PM. Reason: duplicate post
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Old 10-25-2012, 05:14 PM   Thread Starter #25
Official Member
my6thgen.org Profile Info.
 
Stack's Avatar
 
Join Date: Sep 2010
Official Member #: 657
Last Online: 01-12-2019 10:03 PM
Location: Bay Area, California
Posts: 164

Reputation Level: 10
Stack is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: P0420 After HFPC Installed

Replaced the 15525 sensor which is the bottom of sensor of the rear Pre cat. Shortly after the engine light popped back on. Should I replace the front pre cat sensor now?

I haven't had a chance to to check it with the computer but I'm sure it's the same code
Stack is offline   Send a private message to Stack Find more posts by Stack Add Stack to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 0 Guests and 1 Web Crawlers)
 
Thread Tools


All times are GMT -4. The time now is 02:36 AM.