Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Intakes, Headers & Exhaust

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 02-11-2017, 08:26 PM   Thread Starter #1
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default oil light

i have a 2004 nissan maxima with a six speed. after i installed my cai the oil light came on and the rpms were at 500 or a little higher after doing the relearn it still idels at 500 or so and the oil light is still on will this cause any damage? and if so how do i fix it.
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Old 02-11-2017, 11:42 PM   #2
Newbie
my6thgen.org Profile Info.
 
SrRuizolivas's Avatar
 
Join Date: Jun 2012
Official Member #: 5515
Last Online: 12-24-2018 04:34 PM
Location: Ciudad Juarez
Posts: 39

Reputation Level: 0
SrRuizolivas is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by erodriguez23 View Post
i have a 2004 nissan maxima with a six speed. after i installed my cai the oil light came on and the rpms were at 500 or a little higher after doing the relearn it still idels at 500 or so and the oil light is still on will this cause any damage? and if so how do i fix it.
Hi,

Did you replace the OEM air box for the CAI? have you tried putting the OEM box just to know if anything changes?
SrRuizolivas is offline   Send a private message to SrRuizolivas Find more posts by SrRuizolivas Add SrRuizolivas to Your Friends list Reply With Quote top
Old 02-12-2017, 12:16 AM   Thread Starter #3
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by SrRuizolivas View Post
Hi,

Did you replace the OEM air box for the CAI? have you tried putting the OEM box just to know if anything changes?
i have not tried to go back to the stock airbox yet if i do and it fixes it does that mean i cant use the cai
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Old 02-12-2017, 02:36 PM   #4
Official Member
my6thgen.org Profile Info.
 
trilla_one's Avatar
 
Join Date: Aug 2011
Official Member #: 2874
Last Online: 06-11-2017 07:39 PM
Location: miami
Posts: 244

Reputation Level: 8
trilla_one is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

My guess is that it has something to do with the MAF.

On another note, I have a 6MT as well and never thought about getting a CAI..car is plenty fast and sounds great without one (unless you just want it for looks). Just stay on top of maintenance and keep your motor in tip top shape and you'll be fine. Nissan did a good job here.
__________________


"Every generation has to take its place in battling in the struggle for equality"

-Dr. Harry Thomas
trilla_one is offline   Send a private message to trilla_one Find more posts by trilla_one Add trilla_one to Your Friends list Reply With Quote top
Old 02-12-2017, 02:46 PM   Thread Starter #5
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by trilla_one View Post
My guess is that it has something to do with the MAF.

On another note, I have a 6MT as well and never thought about getting a CAI..car is plenty fast and sounds great without one (unless you just want it for looks). Just stay on top of maintenance and keep your motor in tip top shape and you'll be fine. Nissan did a good job here.
I just got it for the sound and alright I will try to clean the maf sensor and see if it changes anything
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Old 02-13-2017, 11:27 PM   #6
Senior Member
my6thgen.org Profile Info.
 
O.G.Nat-tral's Avatar
 
Join Date: Sep 2012
Official Member #: 6274
Last Online: 03-06-2019 08:33 AM
Location: The B.X.
Posts: 695

Reputation Level: 8
O.G.Nat-tral is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Visit O.G.Nat-tral's PS3 Profile Visit O.G.Nat-tral's Twitter Visit O.G.Nat-tral's YouTube
Default Re: oil light

Never heard of this issue but good info...
__________________


Abused VQ
O.G.Nat-tral is offline   Send a private message to O.G.Nat-tral Find more posts by O.G.Nat-tral Add O.G.Nat-tral to Your Friends list Reply With Quote top
Old 02-15-2017, 07:57 PM   #7
Newbie
my6thgen.org Profile Info.
 
SrRuizolivas's Avatar
 
Join Date: Jun 2012
Official Member #: 5515
Last Online: 12-24-2018 04:34 PM
Location: Ciudad Juarez
Posts: 39

Reputation Level: 0
SrRuizolivas is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by erodriguez23 View Post
I just got it for the sound and alright I will try to clean the maf sensor and see if it changes anything
Did you clean it already? Did it work?
SrRuizolivas is offline   Send a private message to SrRuizolivas Find more posts by SrRuizolivas Add SrRuizolivas to Your Friends list Reply With Quote top
Old 02-15-2017, 08:55 PM   #8
Reputable Member
my6thgen.org Profile Info.
 
smittybizzle's Avatar
 
Join Date: Jan 2011
Official Member #: 1598
Last Online: 03-01-2019 11:33 PM
Location: Baltimore,MD
Posts: 2,222

Reputation Level: 21
smittybizzle will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

It has something to do with the MAF sensor. Also just check the car... make sure it is getting proper voltage as well. As others said put the stock box back on then check to see if issues still persist. Good luck.
smittybizzle is offline   Send a private message to smittybizzle Find more posts by smittybizzle Add smittybizzle to Your Friends list Reply With Quote top
Old 02-16-2017, 05:16 PM   Thread Starter #9
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

I cleaned the maf sensor and it did not change anything. Also I will add it only idles low when the car is at normal temperature. No loss of power no rpm jumping no stalling. I'm going to try and clean out the throttle body next.

Last edited by erodriguez23; 02-16-2017 at 10:53 PM.
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Old 02-19-2017, 11:55 PM   #10
Newbie
my6thgen.org Profile Info.
 
SrRuizolivas's Avatar
 
Join Date: Jun 2012
Official Member #: 5515
Last Online: 12-24-2018 04:34 PM
Location: Ciudad Juarez
Posts: 39

Reputation Level: 0
SrRuizolivas is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by erodriguez23 View Post
I cleaned the maf sensor and it did not change anything. Also I will add it only idles low when the car is at normal temperature. No loss of power no rpm jumping no stalling. I'm going to try and clean out the throttle body next.
Hello, hope I'm not late for the party, this friday I cleaned my MAF and throttle body, when placing all back together and turn it on, the revs were at 1250 all warmed up, did the relearn and nothing, then I came across a post here, something about p0507 fixed, the guy had high revs problems too as me, I know your problem its low revs but hope this helps.

P0507 Fixed
SrRuizolivas is offline   Send a private message to SrRuizolivas Find more posts by SrRuizolivas Add SrRuizolivas to Your Friends list Reply With Quote top
Old 02-20-2017, 01:44 PM   Thread Starter #11
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

i cleaned the throttle body and did the relearn now I'm idling around 600-650 and my oil light is still on. I'm going to replace the oil pressure switch and see if that helps with the light. idk what to look for next to raise idle up, and it is getting proper voltage.
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Old 02-20-2017, 01:54 PM   #12
my6thgen.org Profile Info.
 
EddyMaxx's Avatar
 
Join Date: Jan 2010
Official Member #: 1
Location: Bat-Brooklyn, NYC
Posts: 34,307

Reputation Level: 20
EddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to behold

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%


Visit EddyMaxx's Facebook Visit EddyMaxx's PS3 Profile Visit EddyMaxx's YouTube
Default Re: oil light

Need to also check for vaccum leaks.
__________________
04' Nissan Maxima - [Supercharged w/ HR Swapped Motor & Fully Built Auto Trans]
98' Nissan Maxima - [VQ35DE 6-Speed Supercharged]

6thgen 2014 Build Thread
EddyMaxx is offline   Send a private message to EddyMaxx Find more posts by EddyMaxx Add EddyMaxx to Your Friends list Reply With Quote top
Old 02-20-2017, 06:29 PM   #13
Newbie
my6thgen.org Profile Info.
 
SrRuizolivas's Avatar
 
Join Date: Jun 2012
Official Member #: 5515
Last Online: 12-24-2018 04:34 PM
Location: Ciudad Juarez
Posts: 39

Reputation Level: 0
SrRuizolivas is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by erodriguez23 View Post
i cleaned the throttle body and did the relearn now I'm idling around 600-650 and my oil light is still on. I'm going to replace the oil pressure switch and see if that helps with the light. idk what to look for next to raise idle up, and it is getting proper voltage.
Ok, for what I know, the oil light will turn on when there is not much pressure in the switch, so, being at that low RPMs the oil is not having that much pressure, fix the low RPMs and the oil light will go away.
SrRuizolivas is offline   Send a private message to SrRuizolivas Find more posts by SrRuizolivas Add SrRuizolivas to Your Friends list Reply With Quote top
Old 02-20-2017, 10:35 PM   Thread Starter #14
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by SrRuizolivas View Post
Ok, for what I know, the oil light will turn on when there is not much pressure in the switch, so, being at that low RPMs the oil is not having that much pressure, fix the low RPMs and the oil light will go away.
I don't think the oil pressure light should be on if the rpm is only 100 rpm low from normal
That should not affect it that much.
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Old 02-20-2017, 10:36 PM   Thread Starter #15
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

Originally Posted by EddyMaxx View Post
Need to also check for vaccum leaks.
If there is a vacuum leak would it throw a code
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Old 03-03-2017, 11:01 PM   Thread Starter #16
Newbie
my6thgen.org Profile Info.
 
erodriguez23's Avatar
 
Join Date: Feb 2017
Official Member #: 18385
Last Online: 01-15-2018 10:13 PM
Posts: 14

Reputation Level: 0
erodriguez23 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: oil light

So I replaced some emission hose and cleaned some sensors and did the idle relearn another time so now it idles at 700-800 and oil light is still on so next I'm replacing the oil pressure switch
erodriguez23 is offline   Send a private message to erodriguez23 Find more posts by erodriguez23 Add erodriguez23 to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 11:18 AM.