Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Engine, Trans, F/I & Tuning

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 02-16-2014, 01:07 PM   Thread Starter #1
Official Member
my6thgen.org Profile Info.
 
trilla_one's Avatar
 
Join Date: Aug 2011
Official Member #: 2874
Last Online: 06-11-2017 07:39 PM
Location: miami
Posts: 244

Reputation Level: 8
trilla_one is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Single click after startup?

For the past two months i've been getting this fairly audible click from the engine right after the car cranks. Sounds like its coming from the starter area so i'm leaning towards it being a failing starter. I have no starting problems or other noticeable issues otherwise. Any ideas of what it could be?
__________________


"Every generation has to take its place in battling in the struggle for equality"

-Dr. Harry Thomas
trilla_one is offline   Send a private message to trilla_one Find more posts by trilla_one Add trilla_one to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 07:10 AM.