Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Engine, Trans, F/I & Tuning

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 11-04-2013, 01:44 AM   Thread Starter #1
Newbie
my6thgen.org Profile Info.
 
acassim1's Avatar
 
Join Date: Jul 2013
Official Member #: 13386
Last Online: 08-28-2015 05:53 PM
Posts: 4

Reputation Level: 0
acassim1 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default p0021 and p1135 codes

Hey fellas, needed some help here. I'll try to simplify as best I can:

June 2013--Bought the car used from private seller with engine code p1444 code on

Late September 2013--Changed the EVAP canister purge volume control solenoid valve. Cleared the code manually but it immediately came right back on after driving around a little.

October 19—Seafoamed via intake, crankcase and gas tank

October 29th—After driving about 100-150 miles after the seafoam, go for an oil change, and AS I’m pulling up to the oil change shop (before they even change the oil), the engine stutters, stalls, and dies. Does the same thing a few times again before it stays on for good without any problems. Anyways, I get the oil changed and later that day check the engine codes and get the same old p1444 PLUS a p0335 code (Crankshaft Position Sensor A Circuit). It feels almost like a clogged fuel filter but as you guys know there’s a permanent fuel filter in this car and they don’t need replacing.

November 3rd—Car continues to stall and die a few times in between Oct 29 and Nov 3 at first at low RPMs with my foot off the gas only but later also with my foot on the gas at low speeds in the middle of the road. I replaced the Crankshaft Position Sensor with a replacement part with lifetime warranty from AutoZone and reset the engine codes. The car still doesn’t feel right. After driving around a little while (about 6-8 miles), get 2 new codes with the old ones gone—they are p1135 (Intake Valve Timing Control Bank 2 ) and p0021 ("A" Camshaft Position--Timing Over--Advanced or System Performance (Bank 2)).

What should I do? It hasn't stalled on me yet, but then again, I haven't driven it all that much after changing the CPS...

Thanks in advance, any help is appreciated.
acassim1 is offline   Send a private message to acassim1 Find more posts by acassim1 Add acassim1 to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 07:02 AM.