Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Engine, Trans, F/I & Tuning

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 05-01-2013, 04:45 AM   Thread Starter #1
Newbie
my6thgen.org Profile Info.
 
Allblkmax's Avatar
 
Join Date: Apr 2013
Official Member #: 7579
Last Online: 05-11-2013 02:38 PM
Posts: 5

Reputation Level: 0
Allblkmax is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Help Needed With Trouble Code

Hello everyone so I have read a couple of posts on max's stuck in fifth gear so here's my problem maybe someone can help. So my car was stuck in 5th gear so I immediately jump on here and read up I changed out both cam sensors maf sensor until I finally got a code scanner and scanned it it came up to a P0335 crankshaft position sensor A circuit malfunction so I go down and buy that sensor and throw it on clear the code car runs great for about 30 miles then without notice just stays up in 5th gear so I get on home to scan again and come up with the same code I'm so lost I'm hoping someone can help me before I throw my money at a mechanic shop. I highly doubt it my tranny because there's no hard shifts or slipping every gear runs good when I clear the code PLEASE SOMEONE HELP!!
Allblkmax is offline   Send a private message to Allblkmax Find more posts by Allblkmax Add Allblkmax to Your Friends list Reply With Quote top
Old 05-01-2013, 11:18 AM   #2
Newbie
my6thgen.org Profile Info.
 
sam05max's Avatar
 
Join Date: Apr 2011
Official Member #: 2124
Last Online: 04-03-2014 10:51 PM
Location: Houston,Tx
Posts: 6

Reputation Level: 0
sam05max is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Help Needed With Trouble Code

You have a faulty crankshaft sensor. Happened to me last month, same deal. Whatever you do, do not buy aftermarket, spend the dough and buy from the dealer. Its an easy fix, the sensor is located by the bell housing. Once you change the sensor the code should clear and all is well.
sam05max is offline   Send a private message to sam05max Find more posts by sam05max Add sam05max to Your Friends list Reply With Quote top
Old 05-01-2013, 12:42 PM   #3
Newbie
my6thgen.org Profile Info.
 
kylepie24's Avatar
 
Join Date: Feb 2012
Official Member #: 4432
Last Online: 07-13-2015 06:58 PM
Location: Long Island NY
Posts: 69

Reputation Level: 8
kylepie24 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Help Needed With Trouble Code

Try and google it.
__________________
Click the image to open in full size.On that Bombshell
kylepie24 is offline   Send a private message to kylepie24 Find more posts by kylepie24 Add kylepie24 to Your Friends list Reply With Quote top
Old 05-04-2013, 03:50 AM   Thread Starter #4
Newbie
my6thgen.org Profile Info.
 
Allblkmax's Avatar
 
Join Date: Apr 2013
Official Member #: 7579
Last Online: 05-11-2013 02:38 PM
Posts: 5

Reputation Level: 0
Allblkmax is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Help Needed With Trouble Code

Sweet thank you guy for the help. You guys are great so I went and got a new sensor worked for a couple days then all of a sudden there I am again but this time it's just giving me multiple codes every time i scan it difrent codes everytime and the car runs fine when I reset the codes I'm so frustrated and lost. So I have a hunch that it might be my ECM but if anyone has dealt with something like this before I would love to know. Thank again guys.
Allblkmax is offline   Send a private message to Allblkmax Find more posts by Allblkmax Add Allblkmax to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 07:08 AM.