Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Engine, Trans, F/I & Tuning

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 12-19-2012, 03:00 PM   Thread Starter #1
Official Member
my6thgen.org Profile Info.
 
2damax's Avatar
 
Join Date: May 2011
Official Member #: 2405
Last Online: 05-29-2017 02:51 PM
Location: Chicago, florida
Posts: 101

Reputation Level: 9
2damax is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Engine Swap Write Up???

Hey guy its been a while since posting, i view all the time but i ran into a serious issue this weekend. I go to school in florida working on my masters but live in chicago. I got my oild changed and inspected all componets and i was fine. I drove 450 mile to Tennessee and it started raining, I have an InJen CAI which sits in front of the tire. I usually dont drive in the rain but I really didnt have a choice. It really started coming down and i knew I had to get to an underpass. I saw one maybe 2 miles down the road but suddenly my car started stalling and jerking around 3000 rpm. This happend to me before, That CAI suck water up so fast. I got to the underpass and as soon as i stopped the whole car cut off, no power anywhere! I have 3 batteries in my car, I didnt see any blown fuses but that was becasue when I finally found the fust it was encased behind a cloudy plastic piece. Dont know how it blew but I had AAA tow me 50 miles up the road. Found out i needed a fuse that only Nissan supplied so I had to buy an 80amp block fuse and run it from the battery. Car started but my engine was making a knocking noise, I thought maybe i had hydrolocked my car but the car started, I ended up getting an oil change and the knocking went away. I drove another 150 miles stopped got some gas got on the Interstate and barely got off the on ramp before a rod cracked my engine. Mind you I just replaced this engine 7 months ago which is conveniently a month outside the warranty I had on it. anyway had to rent a uhal to pull my maxima the last 350 miles. which cost me $450 plus the gas i had to spend on the 6 miles to the gallon ford i was driving. I Just bought another engine and I want to swap them out myself and i searched All over the web to see if anyone had a write up. any help would be great. ironically i had just received my OEM valve body and painted my car the day before. Ugh!!!!
__________________
Click the image to open in full size.
Kinetik Intake Mainifold
injen CAI
Deleted Cat
Greddy Spectre Elite Exhaust
Drilled & Slotted Rotors
22" TSW Rims
2damax is offline   Send a private message to 2damax Find more posts by 2damax Add 2damax to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 08:52 PM.