Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > Ask Your Technical & General Questions > Engine, Trans, F/I & Tuning

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 08-24-2011, 05:10 AM   Thread Starter #1
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default 2006 Maxima SL Misfiring? Struggling?

i have a 06 Maxima SL Auto with 36k, my car is giving me problems, after about 15 mins or more of driving, my car starts to struggle between 1500rpm-2200rpm, ( before 1500 rpm & after 2200 rpm the car drives fine with no problems ) i thought it was a misfire but mechanic checked out all the spark plug, coil and found nothing, he plugged in the computer to see if he can find the problem and found nothing. so now i took it to another shop and one mechanic said it can be the throttle body, can the throttle body actually cause this problem? if not what else can it be? what can i do to fix this problem?
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 08-24-2011, 05:30 AM   #2
Senior Moderator

my6thgen.org Profile Info.
 
1hawaii50's Avatar
 
Join Date: Feb 2010
Official Member #: 63
Last Online: 11-03-2014 08:34 PM
Location: Cleveland, Ohio
Posts: 13,276

Reputation Level: 58
1hawaii50 has a spectacular aura about1hawaii50 has a spectacular aura about1hawaii50 has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Supporting Family Member  


/ Point Value: 10

Member of the Month (M.O.T.M)  


/ Point Value: 10

Most Valuable Poster (MVP)  


/ Point Value: 10

V.I.P Member  


/ Point Value: 15

Spotlight Ride Of The Month  


/ Point Value: 5

Active Member  


/ Point Value: 5

Official Ride  


/ Point Value: 10

Default Re: 2006 Maxima SL misfiring? struggling?

Maybe your MAF?

Did I read your original post correctly, you only have 36K miles on your 06? That's pretty impressive!
__________________
1hawaii50 is offline   Send a private message to 1hawaii50 Find more posts by 1hawaii50 Add 1hawaii50 to Your Friends list Reply With Quote top
Old 08-24-2011, 05:49 AM   Thread Starter #3
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL misfiring? struggling?

Mass Air Flow sensor? No I did not check it out, I will tell the mechanic tomorrow to take a look at it.

Yes you read right it has 36k, I dont drive much only when I'm off, I work 4.4 miles away from home.

By the way I forgot to mention it does not have a check engine light on, and it never did in the past.
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 08-24-2011, 07:20 AM   #4
Official Member
my6thgen.org Profile Info.
 
KRod877's Avatar
 
Join Date: Aug 2010
Official Member #: 449
Last Online: 04-19-2016 12:22 AM
Location: Springfield, MA
Posts: 111

Reputation Level: 10
KRod877 is an unknown quantity at this point

Participation Level: 2%
Activity: 2% Activity: 2% Activity: 2%
Default Re: 2006 Maxima SL Misfiring? Struggling?

What Kind of gas do u Use?? 93 ALL THE WAY I HOPE????
KRod877 is offline   Send a private message to KRod877 Find more posts by KRod877 Add KRod877 to Your Friends list Reply With Quote top
Old 08-24-2011, 07:25 AM   #5
my6thgen.org Profile Info.
 
Hmax's Avatar
 
Join Date: Mar 2010
Official Member #: 158
Last Online: 11-12-2019 01:10 PM
Location: Da Bronx, NY
Posts: 5,926

Reputation Level: 32
Hmax will become famous soon enoughHmax will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Most Valuable Poster (MVP)  


/ Point Value: 10

Active Member  


/ Point Value: 5

Default Re: 2006 Maxima SL Misfiring? Struggling?

Get the code read at autozone and go from there, the light is on for a reason. keep us posted
__________________
Originally Posted by hero782 View Post
Low & Slow!!! And I stop at potholes lol
Click the image to open in full size.

Want 12HP More?- CLICK HERE
Hmax is offline   Send a private message to Hmax Find more posts by Hmax Add Hmax to Your Friends list Reply With Quote top
Old 08-24-2011, 08:02 AM   #6
Senior Moderator
The Capital's 6th Gen
my6thgen.org Profile Info.
 
officerfrasher's Avatar
 
Join Date: Feb 2011
Official Member #: 1765
Last Online: 06-01-2018 10:32 AM
Location: Frankfort, KY 40601
Posts: 13,375

Reputation Level: 58
officerfrasher has a spectacular aura aboutofficerfrasher has a spectacular aura aboutofficerfrasher has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Member of the Month (M.O.T.M)  


/ Point Value: 10

Supporting Family Member  


/ Point Value: 10

Official Ride  


/ Point Value: 10

Spotlight Ride Of The Month  


/ Point Value: 5

Default Re: 2006 Maxima SL Misfiring? Struggling?

Originally Posted by Hmax View Post
Get the code read at autozone and go from there, the light is on for a reason. keep us posted
He said NO CEL light on, end of post #3.
Likes: (1)
alum (08-24-2011)
officerfrasher is offline   Send a private message to officerfrasher Find more posts by officerfrasher Add officerfrasher to Your Friends list Reply With Quote top
Old 08-24-2011, 10:52 AM   Thread Starter #7
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

Yes I use only 93, nothing lower, I usually use bp sometimes I'll use hess but even when I do I make sure the needle is close to empty so I won't mix with bp

And yes I do not have a CEL, sorry I did not post that on the 1st post
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 08-25-2011, 12:39 AM   Thread Starter #8
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

well the mechanic suggested i take it to Nissan Dealer, so we dropped it off so let see what will be the outcome
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 08-25-2011, 04:33 PM   #9
Premier Member
my6thgen.org Profile Info.
 
NiZMo1o1's Avatar
 
Join Date: May 2010
Official Member #: 211
Last Online: 10-20-2016 11:20 AM
Location: Wade County ! down in Sunny Florida
Posts: 5,222

Reputation Level: 42
NiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura about

Participation Level: 20%
Activity: 20% Activity: 20% Activity: 20%

My Awards:
Supporting Family Member  


/ Point Value: 10

Member of the Month (M.O.T.M)  


/ Point Value: 10

Default Re: 2006 Maxima SL Misfiring? Struggling?

Originally Posted by LaCuRa View Post
well the mechanic suggested i take it to Nissan Dealer, so we dropped it off so let see what will be the outcome
Sounds like the MAF needs to be cleaning, another reason it would misfire is a clog injector or clog cats.

but usually the CEL would trigger for a clog cats.

MAF would be my first step.

the DBW TB ( Drive By Wire ) Throttle body has known to go bad , it sticks but the car would go into limp mode and you wont be able to drive past 5mph.
__________________
Click the image to open in full size.
Click the image to open in full size.
R.I.P. Kevin007www.EmeraldPerformance.com
NiZMo1o1 is offline   Send a private message to NiZMo1o1 Find more posts by NiZMo1o1 Add NiZMo1o1 to Your Friends list Reply With Quote top
Old 09-03-2011, 04:43 PM   #10
Official Member
my6thgen.org Profile Info.
 
05vk56's Avatar
 
Join Date: Sep 2011
Official Member #: 3022
Last Online: 01-07-2014 03:50 PM
Posts: 134

Reputation Level: 21
05vk56 will become famous soon enough05vk56 will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

It can't be the throttle body, it would go into limp mode as Nizmo said, and it would do it through entire rpm band, not just between 1.5k to 2.2k. I would look into MAF, and also look into seeing if there is any vacuum line loose.
05vk56 is offline   Send a private message to 05vk56 Find more posts by 05vk56 Add 05vk56 to Your Friends list Reply With Quote top
Old 09-03-2011, 08:02 PM   Thread Starter #11
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

Well its been in the shop for 2 weeks & 1 week at the nissan service, & they cant find the problem but they think it might be the radiator & coolant sensor, so they going to start with that if that is not the problem the next step is to replace the computer, so I'm waiting for the outcome, I really don't want to spend more $ because I'm trying to save up for another car but hopefully I won't have to replace the computer, I got my fingers cross lol
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 09-03-2011, 08:24 PM   #12
Newbie
my6thgen.org Profile Info.
 
Canammaxima's Avatar
 
Join Date: May 2011
Official Member #: 2402
Last Online: 09-21-2012 10:57 AM
Location: Massachusettes
Posts: 79

Reputation Level: 9
Canammaxima is an unknown quantity at this point

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: 2006 Maxima SL Misfiring? Struggling?

Check your EGR Valve. My old car b4 my 6th gen ran horrible at those rpms and frequently stalled, felt like it was misfiring and i even thought the tranny was bad. But i did some online research and cleaned out the egr valve and she ran like a champ.
Canammaxima is offline   Send a private message to Canammaxima Find more posts by Canammaxima Add Canammaxima to Your Friends list Reply With Quote top
Old 09-03-2011, 08:45 PM   Thread Starter #13
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

It's at the shop now (since 2-3 weeks) so I can't do anything, but thanks for the suggestions, if they can't figure out the problem then I'm just sell it
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 09-03-2011, 10:26 PM   #14
The Bandit
my6thgen.org Profile Info.
 
K-Ryder's Avatar
 
Join Date: Jan 2010
Official Member #: 15
Last Online: 09-19-2015 08:34 PM
Location: Brooklyn
Posts: 3,401

Reputation Level: 23
K-Ryder will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Visit K-Ryder's Facebook Visit K-Ryder's PS3 Profile Visit K-Ryder's YouTube
Default Re: 2006 Maxima SL Misfiring? Struggling?

You might have a vacuum leak somewhere
__________________
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
K-Ryder is offline   Send a private message to K-Ryder Find more posts by K-Ryder Add K-Ryder to Your Friends list Reply With Quote top
Old 09-04-2011, 12:04 AM   #15
Official Member
my6thgen.org Profile Info.
 
04max28's Avatar
 
Join Date: May 2011
Official Member #: 2406
Last Online: 08-22-2013 07:17 PM
Location: NYC
Posts: 138

Reputation Level: 9
04max28 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Visit 04max28's Facebook Visit 04max28's PS3 Profile
Default Re: 2006 Maxima SL Misfiring? Struggling?

where is the EGR valve in our maximas?
04max28 is offline   Send a private message to 04max28 Find more posts by 04max28 Add 04max28 to Your Friends list Reply With Quote top
Old 09-04-2011, 05:09 AM   Thread Starter #16
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

No vacuum leak, egr valve good, throttle body good, maf good, it only does it after about 10-15mins of driving so I could believe the radiator and coolant sensor could be it
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 09-04-2011, 05:09 PM   #17
Newbie
my6thgen.org Profile Info.
 
bhp4202's Avatar
 
Join Date: Sep 2010
Official Member #: 747
Last Online: 07-31-2018 02:48 PM
Location: Syracuse, NY
Posts: 95

Reputation Level: 10
bhp4202 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

3 months ago i had same kinda of thing happen to me while i was driving and no cel on but i found that on driverside under hood on the wheelwell infront where you fill brake fluid there are 2 grey and 1 black clips check the top grey 1 wires my wires to intake air temp sensor started to come out of back end of clip causeing the problems and not until it broke is when cel came on and directed me to those clips to find wire broke off i just solder the wires and taped them haven't had any issues since. i will upload a pic on my profile in a few mins for location.
bhp4202 is offline   Send a private message to bhp4202 Find more posts by bhp4202 Add bhp4202 to Your Friends list Reply With Quote top
Old 09-04-2011, 07:11 PM   #18
The Bandit
my6thgen.org Profile Info.
 
K-Ryder's Avatar
 
Join Date: Jan 2010
Official Member #: 15
Last Online: 09-19-2015 08:34 PM
Location: Brooklyn
Posts: 3,401

Reputation Level: 23
K-Ryder will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Active Member  


/ Point Value: 5

Visit K-Ryder's Facebook Visit K-Ryder's PS3 Profile Visit K-Ryder's YouTube
Default Re: 2006 Maxima SL Misfiring? Struggling?

Do the spark plugs have signs of oil on them?
__________________
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
K-Ryder is offline   Send a private message to K-Ryder Find more posts by K-Ryder Add K-Ryder to Your Friends list Reply With Quote top
Old 09-04-2011, 08:02 PM   Thread Starter #19
Official Member
my6thgen.org Profile Info.
 
LaCuRa's Avatar
 
Join Date: Oct 2010
Official Member #: 915
Last Online: 02-23-2013 05:33 AM
Location: New York
Posts: 113

Reputation Level: 10
LaCuRa is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

Originally Posted by bhp4202 View Post
3 months ago i had same kinda of thing happen to me while i was driving and no cel on but i found that on driverside under hood on the wheelwell infront where you fill brake fluid there are 2 grey and 1 black clips check the top grey 1 wires my wires to intake air temp sensor started to come out of back end of clip causeing the problems and not until it broke is when cel came on and directed me to those clips to find wire broke off i just solder the wires and taped them haven't had any issues since. i will upload a pic on my profile in a few mins for location.
This is something new,i will look into that on tuesday, if you can post some pics it will help out alot also but I will look into this tuesday before they even change the radiator and coolant sensor on the car
LaCuRa is offline   Send a private message to LaCuRa Find more posts by LaCuRa Add LaCuRa to Your Friends list Reply With Quote top
Old 09-04-2011, 08:54 PM   #20
Quicksilver
my6thgen.org Profile Info.
 
RAZ76's Avatar
 
Join Date: Feb 2010
Official Member #: 138
Last Online: 04-30-2015 12:24 PM
Location: ANAHEIM/OKC
Posts: 7,612

Reputation Level: 50
RAZ76 is a jewel in the roughRAZ76 is a jewel in the roughRAZ76 is a jewel in the rough

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%

My Awards:
Member of the Month (M.O.T.M)  


/ Point Value: 10

Banner of The Month  


/ Point Value: 10

Official Ride  


/ Point Value: 10

Default Re: 2006 Maxima SL Misfiring? Struggling?

What code did they pull?? You keep saying that they found nothing but when CEL light comes on, there's a code.
__________________
Click the image to open in full size.
RAZ76 is offline   Send a private message to RAZ76 Find more posts by RAZ76 Add RAZ76 to Your Friends list Reply With Quote top
Old 09-05-2011, 03:23 AM   #21
Premier Member
my6thgen.org Profile Info.
 
NiZMo1o1's Avatar
 
Join Date: May 2010
Official Member #: 211
Last Online: 10-20-2016 11:20 AM
Location: Wade County ! down in Sunny Florida
Posts: 5,222

Reputation Level: 42
NiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura about

Participation Level: 20%
Activity: 20% Activity: 20% Activity: 20%

My Awards:
Supporting Family Member  


/ Point Value: 10

Member of the Month (M.O.T.M)  


/ Point Value: 10

Default Re: 2006 Maxima SL Misfiring? Struggling?

After re-reading this , I forgot the oblivious ,

Coil Packs could be bad as well if its a mis-fire, its not a ECU problem , if the ECU was done for , your car wouldn't be running.

and as well post #17 , check all the connections, I know you said its at Nissan so have them check it out before they try to rip you a new hole.
__________________
Click the image to open in full size.
Click the image to open in full size.
R.I.P. Kevin007www.EmeraldPerformance.com
NiZMo1o1 is offline   Send a private message to NiZMo1o1 Find more posts by NiZMo1o1 Add NiZMo1o1 to Your Friends list Reply With Quote top
Old 09-05-2011, 08:32 AM   #22
Newbie
my6thgen.org Profile Info.
 
bhp4202's Avatar
 
Join Date: Sep 2010
Official Member #: 747
Last Online: 07-31-2018 02:48 PM
Location: Syracuse, NY
Posts: 95

Reputation Level: 10
bhp4202 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

this is from my post from june 2011...Had ses light on came back P0113 intake air temp sensor/ circuit. Found the wire broke off gray chip on the harness next to brake fluid reservoir. There are 3 clips on this bracket bolted to fender but the wire broke inside gray clip in the plastic

Read more: http://my6thgen.org/showthread.php?p...#ixzz1X5439aQg
bhp4202 is offline   Send a private message to bhp4202 Find more posts by bhp4202 Add bhp4202 to Your Friends list Reply With Quote top
Old 09-05-2011, 08:52 AM   #23
Newbie
my6thgen.org Profile Info.
 
bhp4202's Avatar
 
Join Date: Sep 2010
Official Member #: 747
Last Online: 07-31-2018 02:48 PM
Location: Syracuse, NY
Posts: 95

Reputation Level: 10
bhp4202 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

make sure the car is running when they check the wire on the top clip wiggle the wire and if thats it your motor will tell you she will be choking and spitting that's what mine did. i have a pic i uploaded to my profile but i still don't no how to post yet?
bhp4202 is offline   Send a private message to bhp4202 Find more posts by bhp4202 Add bhp4202 to Your Friends list Reply With Quote top
Old 09-05-2011, 09:36 AM   #24
Senior Moderator
my6thgen.org Profile Info.
 
Chemax's Avatar
 
Join Date: Feb 2010
Official Member #: 140
Last Online: 10-04-2014 01:46 PM
Location: SATX
Posts: 11,313

Reputation Level: 51
Chemax has a spectacular aura aboutChemax has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Supporting Family Member  


/ Point Value: 10

Active Member  


/ Point Value: 5

Default Re: 2006 Maxima SL Misfiring? Struggling?

Originally Posted by bhp4202 View Post
make sure the car is running when they check the wire on the top clip wiggle the wire and if thats it your motor will tell you she will be choking and spitting that's what mine did. i have a pic i uploaded to my profile but i still don't no how to post yet?
Don't know how to post a pic?

You can use the image hosting on the site or use the URL for the image if it's from your photobucket account.

Personally, I think it's easiest to use imgur.com or min.us for image hosting and paste the URL in the "attach image" button in the reply area. Pretty easy, good luck!
__________________
Click the image to open in full size.
We all have different ways of coping - I use sex and awesomeness.

mmm.... chorizo
-csiepka
Chemax is offline   Send a private message to Chemax Find more posts by Chemax Add Chemax to Your Friends list Reply With Quote top
Old 09-05-2011, 10:17 AM   #25
Newbie
my6thgen.org Profile Info.
 
bhp4202's Avatar
 
Join Date: Sep 2010
Official Member #: 747
Last Online: 07-31-2018 02:48 PM
Location: Syracuse, NY
Posts: 95

Reputation Level: 10
bhp4202 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: 2006 Maxima SL Misfiring? Struggling?

Click the image to open in full size.
bhp4202 is offline   Send a private message to bhp4202 Find more posts by bhp4202 Add bhp4202 to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 03:56 PM.