Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > How To's & DIY Mods > Engine, Trans, F/I & Tuning

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 01-29-2016, 09:31 PM   Thread Starter #1
Newbie
my6thgen.org Profile Info.
 
mycotopian's Avatar
 
Join Date: Dec 2015
Official Member #: 17370
Last Online: 08-11-2016 09:18 PM
Posts: 5

Reputation Level: 0
mycotopian is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default VB repair didnt resolve my issue

Hey guys,

I followed the rpsuprdave guide2004 - 2006 Valve Body Replacement for the valve body repair over the past few days.

Unfortunately it did not resolve my issue.

After completing the repair and taking the car out to "relearn" the shifting remained erratic. Eventually it would only pull away from a stop in what felt like 3rd or 4th gear.


Is there soomething I could have overlooked that can cause this? Hopefully this doesn't mean the trans is toast.

Any help or feedback would be appreciated . Thanks!
mycotopian is offline   Send a private message to mycotopian Find more posts by mycotopian Add mycotopian to Your Friends list Reply With Quote top
Old 01-30-2016, 09:20 AM   #2
Senior Member
my6thgen.org Profile Info.
 
Zillafreak's Avatar
 
Join Date: Mar 2015
Official Member #: 16528
Last Online: 06-07-2017 10:17 AM
Posts: 520

Reputation Level: 6
Zillafreak is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

good fluid levels?
TC good?
Any codes?
__________________
Click the image to open in full size.
Zillafreak is offline   Send a private message to Zillafreak Find more posts by Zillafreak Add Zillafreak to Your Friends list Reply With Quote top
Old 01-30-2016, 12:24 PM   Thread Starter #3
Newbie
my6thgen.org Profile Info.
 
mycotopian's Avatar
 
Join Date: Dec 2015
Official Member #: 17370
Last Online: 08-11-2016 09:18 PM
Posts: 5

Reputation Level: 0
mycotopian is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

Originally Posted by Zillafreak View Post
good fluid levels?
TC good?
Any codes?
Fluids: I had the drain plug out and the pan off for a few days while working. After I sealed it up I added about 4 quarts.

"TC" : is that traction control?

Codes: P080

Thanks!
mycotopian is offline   Send a private message to mycotopian Find more posts by mycotopian Add mycotopian to Your Friends list Reply With Quote top
Old 01-30-2016, 01:17 PM   #4
Senior Member
my6thgen.org Profile Info.
 
Zillafreak's Avatar
 
Join Date: Mar 2015
Official Member #: 16528
Last Online: 06-07-2017 10:17 AM
Posts: 520

Reputation Level: 6
Zillafreak is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

TC = Torque converter.

And P080, you might be missing a number somewhere.
__________________
Click the image to open in full size.
Zillafreak is offline   Send a private message to Zillafreak Find more posts by Zillafreak Add Zillafreak to Your Friends list Reply With Quote top
Old 01-30-2016, 02:24 PM   Thread Starter #5
Newbie
my6thgen.org Profile Info.
 
mycotopian's Avatar
 
Join Date: Dec 2015
Official Member #: 17370
Last Online: 08-11-2016 09:18 PM
Posts: 5

Reputation Level: 0
mycotopian is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

The code I am getting is P0780 - shift

I did not know to check the torque converter. How do I go about doing that?

btw I installed everything as is from valve body pros. I did not attemtept to calibrate anything. I also filled it up with synthetic mobil 1 atf .

Last edited by mycotopian; 01-30-2016 at 04:32 PM.
mycotopian is offline   Send a private message to mycotopian Find more posts by mycotopian Add mycotopian to Your Friends list Reply With Quote top
Old 01-30-2016, 05:11 PM   #6
Senior Member
my6thgen.org Profile Info.
 
Zillafreak's Avatar
 
Join Date: Mar 2015
Official Member #: 16528
Last Online: 06-07-2017 10:17 AM
Posts: 520

Reputation Level: 6
Zillafreak is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

Just looked at the fluid, it doesn't say it meets Nissan Matic-K specs.

According to ExxonMobil, Mobil 1 Synthetic ATF is of the following quality level:
Allison C-4
General Motors Dexron IIIH
General Motors Dexron IIIG
General Motors Dexron IIE
General Motors Dexron IID
General Motors Dexron II
General Motors Dexron
Ford Mercon
Voith H55.6335.3X
MAN 339 V1
Volvo 97340
Volvo 97341

This might be the issue?
__________________
Click the image to open in full size.
Zillafreak is offline   Send a private message to Zillafreak Find more posts by Zillafreak Add Zillafreak to Your Friends list Reply With Quote top
Old 01-30-2016, 05:18 PM   #7
Senior Member
my6thgen.org Profile Info.
 
Zillafreak's Avatar
 
Join Date: Mar 2015
Official Member #: 16528
Last Online: 06-07-2017 10:17 AM
Posts: 520

Reputation Level: 6
Zillafreak is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

The P0780 code.
Possible causes
- Low transmission fluid level
- Dirty transmission fluid
- Faulty shifting solenoid valve
- Shifting solenoid valve harness is open or shorted
- Shifting solenoid valve circuit poor electrical connection


So check your fluids level, I think the stuff you used might not be the right fluid anyways.
__________________
Click the image to open in full size.
Zillafreak is offline   Send a private message to Zillafreak Find more posts by Zillafreak Add Zillafreak to Your Friends list Reply With Quote top
Old 01-30-2016, 07:18 PM   #8
Senior Member
my6thgen.org Profile Info.
 
Dannyky2's Avatar
 
Join Date: Dec 2013
Official Member #: 14651
Last Online: 10-15-2018 11:38 PM
Location: Phoenix, AZ
Posts: 512

Reputation Level: 7
Dannyky2 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Visit Dannyky2's PS3 Profile
Default Re: VB repair didnt resolve my issue

+1 on the fluid used. These transmissions are very sensitive and using the wrong fluid type could definitely cause issues.
Dannyky2 is offline   Send a private message to Dannyky2 Find more posts by Dannyky2 Add Dannyky2 to Your Friends list Reply With Quote top
Old 01-30-2016, 10:26 PM   #9
Newbie
my6thgen.org Profile Info.
 
Rg541's Avatar
 
Join Date: Sep 2010
Official Member #: 830
Last Online: 03-24-2017 07:45 PM
Location: S. Lake Tahoe, CA.
Posts: 16

Reputation Level: 0
Rg541 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

Nissan Transmission Repair: http://www.youtube.com/playlist?list...zlxYCe1JE4EFh2

Watch this guys videos ..he has a few if them ..he mentions in this video that the valve body only Fix's some tranny...
Rg541 is offline   Send a private message to Rg541 Find more posts by Rg541 Add Rg541 to Your Friends list Reply With Quote top
Old 02-01-2016, 06:05 PM   Thread Starter #10
Newbie
my6thgen.org Profile Info.
 
mycotopian's Avatar
 
Join Date: Dec 2015
Official Member #: 17370
Last Online: 08-11-2016 09:18 PM
Posts: 5

Reputation Level: 0
mycotopian is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

I tore into it this morning. Flipped my bracket that holds down the solenoids. Did a quick relearn in the driveway and took it for a test drive. It's shifts silky smoooth now. Thanks for all the help guys!

Now on to the rest of the list....
mycotopian is offline   Send a private message to mycotopian Find more posts by mycotopian Add mycotopian to Your Friends list Reply With Quote top
Old 02-02-2016, 12:37 PM   #11
Senior Member
my6thgen.org Profile Info.
 
Zillafreak's Avatar
 
Join Date: Mar 2015
Official Member #: 16528
Last Online: 06-07-2017 10:17 AM
Posts: 520

Reputation Level: 6
Zillafreak is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: VB repair didnt resolve my issue

i assume you are talking about inside the VB?
__________________
Click the image to open in full size.
Zillafreak is offline   Send a private message to Zillafreak Find more posts by Zillafreak Add Zillafreak to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 02:39 AM.