Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > How To's & DIY Mods > Engine, Trans, F/I & Tuning

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 09-23-2011, 07:00 PM   Thread Starter #1
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default How to Install VSS Sensor

Here is my how to change vss sensor...
My car is a 2004 but should work 04-06

1-10 difficulty I rate it a 2

Tools needed 10mm socket and ratchet

Here is the part number
Click the image to open in full size.

Here is what the sensor looks like
Click the image to open in full size.

Ok first remove your negative battery wire
Next remove your cai/factory intake

Now right on top the transmission your gonna see a small blue plug
Click the image to open in full size.

And this is the sensor. It has two wires going into it
Click the image to open in full size.

Take your ratchet an remove the one 10pm screw holding the sensor down. Now that you have the screw out; give the sensor a little tug to pull it out.

Should look like this when you pull it out
Click the image to open in full size.

Now take your new sensor, push it down till you hear a little "snap" then put your screw back it. I'm not shure how much to torque it down so I just put it snug. Now reinstall your battery ground cable then go set your clock and radio back.

Comments
  
  good post
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 09-23-2011, 09:31 PM   #2
Mile High City 6th Gen
my6thgen.org Profile Info.
 
vitec115's Avatar
 
Join Date: Aug 2010
Official Member #: 483
Last Online: 07-11-2014 12:08 PM
Location: Colorado
Posts: 1,553

Reputation Level: 15
vitec115 is on a distinguished road

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Visit vitec115's PS3 Profile Visit vitec115's Xbox Gamercard
Default Re: DIY VSS Sensor Install

why did you replace this?
__________________
Click the image to open in full size.
vitec115 is offline   Send a private message to vitec115 Find more posts by vitec115 Add vitec115 to Your Friends list Reply With Quote top
Old 09-24-2011, 12:04 AM   Thread Starter #3
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: DIY VSS Sensor Install

It's a sensor that reads how fast your going an sends signal to speedo. My speedo stopped working an this was the problem. If you have abs light, brake light, and your speedo or cruise don't work.... This $200 sensor is the problem.

Ok guys here is my new problem.

I crank car up and abs, hand brake light on, speedo, and cruise don't work. So I turn car off.
Crank it up again an speedo don't work for couple seconds intill abs light comes on.

Diagnostic test showed open/closed vss circuit or vss sensor
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 09-24-2011, 12:07 AM   #4
my6thgen.org Profile Info.
 
EddyMaxx's Avatar
 
Join Date: Jan 2010
Official Member #: 1
Location: Bat-Brooklyn, NYC
Posts: 34,328

Reputation Level: 20
EddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to beholdEddyMaxx is a splendid one to behold

Participation Level: 100%
Activity: 100% Activity: 100% Activity: 100%


Visit EddyMaxx's Facebook Visit EddyMaxx's PS3 Profile Visit EddyMaxx's YouTube
Default Re: DIY VSS Sensor Install

Nice writeup man!!
__________________
04' Nissan Maxima - [Supercharged w/ HR Swapped Motor & Fully Built Auto Trans]
98' Nissan Maxima - [VQ35DE 6-Speed Supercharged]

6thgen 2014 Build Thread
Likes: (2)
LucKie1nE (09-24-2011), twisted1 (09-24-2011)
EddyMaxx is offline   Send a private message to EddyMaxx Find more posts by EddyMaxx Add EddyMaxx to Your Friends list Reply With Quote top
Old 09-24-2011, 01:49 AM   #5
Team Street Wandererz
my6thgen.org Profile Info.
 
LucKie1nE's Avatar
 
Join Date: Jul 2011
Official Member #: 2672
Last Online: 09-25-2015 04:08 AM
Location: Boston, MA
Posts: 945

Reputation Level: 16
LucKie1nE will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Visit LucKie1nE's PS3 Profile Visit LucKie1nE's YouTube Visit LucKie1nE's Xbox Gamercard
Default Re: DIY VSS Sensor Install

Originally Posted by twisted1 View Post
It's a sensor that reads how fast your going an sends signal to speedo. My speedo stopped working an this was the problem. If you have abs light, brake light, and your speedo or cruise don't work.... This $200 sensor is the problem.

Ok guys here is my new problem.

I crank car up and abs, hand brake light on, speedo, and cruise don't work. So I turn car off.
Crank it up again an speedo don't work for couple seconds intill abs light comes on.

Diagnostic test showed open/closed vss circuit or vss sensor
You did say that it had to VSS sensors.. Maybe the problem is the other VSS sensor..? What is the actual code..?
__________________
Click the image to open in full size.
TEAM STREET WANDERERZ
R.I.P. Philly Ngoc Le & Lylah Nguyen..
LucKie1nE is offline   Send a private message to LucKie1nE Find more posts by LucKie1nE Add LucKie1nE to Your Friends list Reply With Quote top
Old 09-24-2011, 03:27 AM   Thread Starter #6
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: DIY VSS Sensor Install

Yeah I thought there where 2 sensors but Nissan said there is only 1. I'm going to Nissan in the am to see if I have any broken wires.
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 09-24-2011, 05:46 PM   Thread Starter #7
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: DIY VSS Sensor Install

Anybody know why speedo not working still?
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 09-24-2011, 06:06 PM   #8
Premier Member
my6thgen.org Profile Info.
 
NiZMo1o1's Avatar
 
Join Date: May 2010
Official Member #: 211
Last Online: 10-20-2016 11:20 AM
Location: Wade County ! down in Sunny Florida
Posts: 5,222

Reputation Level: 42
NiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura about

Participation Level: 20%
Activity: 20% Activity: 20% Activity: 20%

My Awards:
Supporting Family Member  


/ Point Value: 10

Member of the Month (M.O.T.M)  


/ Point Value: 10

Default Re: DIY VSS Sensor Install

From the look of the sensor its magnetic picked VS the older VSS on the 4spd Auto Maxima that had teeth marks.

If you already RE-SET the ECU and this issue is still happening.

Troubleshoot the plug , jack up the car and take voltage readings (5V) pulses at the connector when the front wheel is turn by hand. You can do this after removing the the VSS and spin the drive link on the VSS by hand. This will eliminate any problems with the drive gears (where the VSS sits on.) If no pulses are found, confirm input voltages then inspect the inside of the VSS also with the Ohnmeter check for Ground , should only be 2 wires.

If the plug checks out OK , it could be your cluster has gone out and tripping the SES code

Also when you removed the old one, was the surface dirty or worn down ?


I'm guessing the speedo cluster is broken if you already replace the VSS
__________________
Click the image to open in full size.
Click the image to open in full size.
R.I.P. Kevin007www.EmeraldPerformance.com
NiZMo1o1 is offline   Send a private message to NiZMo1o1 Find more posts by NiZMo1o1 Add NiZMo1o1 to Your Friends list Reply With Quote top
Old 09-24-2011, 07:25 PM   Thread Starter #9
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: DIY VSS Sensor Install

Here is the symptoms...

Start car no warning lights on
Get down the road the speedo reads 20mph an I'm doing 60
Git alittle further down the road an the abs ligh comes on. Now speedo works

It does this with both my old sensor an new one

I'll pay anyone who can help me figure out my problem. I'll paypal you money or send money order!!!! Please help guys
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 09-24-2011, 08:00 PM   #10
Premier Member
my6thgen.org Profile Info.
 
NiZMo1o1's Avatar
 
Join Date: May 2010
Official Member #: 211
Last Online: 10-20-2016 11:20 AM
Location: Wade County ! down in Sunny Florida
Posts: 5,222

Reputation Level: 42
NiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura aboutNiZMo1o1 has a spectacular aura about

Participation Level: 20%
Activity: 20% Activity: 20% Activity: 20%

My Awards:
Supporting Family Member  


/ Point Value: 10

Member of the Month (M.O.T.M)  


/ Point Value: 10

Default Re: DIY VSS Sensor Install

sounds like the TCM needs to be reprogram , this is the only thing I can think of,

on the newer cluster you can't adjust the speedo , it needs to be recalibrate by the dealer thru the TCM
__________________
Click the image to open in full size.
Click the image to open in full size.
R.I.P. Kevin007www.EmeraldPerformance.com
NiZMo1o1 is offline   Send a private message to NiZMo1o1 Find more posts by NiZMo1o1 Add NiZMo1o1 to Your Friends list Reply With Quote top
Old 09-24-2011, 08:06 PM   Thread Starter #11
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: DIY VSS Sensor Install

I'm thinking about pulling the cluster off an making shure all the screws an plugs are right. I still have a date with Nissan Monday. I couldn't go today because they had alot of people there
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 09-25-2011, 03:42 PM   Thread Starter #12
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: DIY VSS Sensor Install

ok so I walk outside to my car this morning, and I hear this buzzing/humming noise. I pop open hood and this little square motor thing around the ac blower is just humming. The aluminum lines around it where cold an I havnt started the car in like 10hours.....

I go to start the car an my speedo is working, but when I kill it the small pump still hums.
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 09-25-2011, 03:45 PM   Thread Starter #13
Senior Member
my6thgen.org Profile Info.
 
twisted1's Avatar
 
Join Date: Dec 2010
Official Member #: 1494
Last Online: 02-11-2012 05:14 AM
Location: louisiana
Posts: 626

Reputation Level: 13
twisted1 is on a distinguished road

Participation Level: 3%
Activity: 3% Activity: 3% Activity: 3%
Default Re: DIY VSS Sensor Install

isnt it the abs pump trying to repressurize its self? That would explain the cold lines.
__________________
Stillen lip kit, black housed headlamps, 370z 18s, 350z 17's on drs, blue led fogs, aem wideband o2,apexi safcll, 75shot zex wet kit, skunk2 cans, custom y&b pipes, 3rd cat & resonator delete, magnaflow precats, nwp spacers, kn cai, and walbro 255 still in box. Dyno #s coming soon....
twisted1 is offline   Send a private message to twisted1 Find more posts by twisted1 Add twisted1 to Your Friends list Reply With Quote top
Old 12-22-2011, 02:58 AM   #14
Newbie
my6thgen.org Profile Info.
 
lockMAX's Avatar
 
Join Date: Dec 2010
Official Member #: 1345
Last Online: 11-15-2012 12:33 AM
Location: okc, ok
Posts: 52

Reputation Level: 9
lockMAX is an unknown quantity at this point

Participation Level: 5%
Activity: 5% Activity: 5% Activity: 5%
Default Re: How to Install VSS Sensor

did u ever figure out ur problem wit ur speedo not working im having a similar problem right now my speedo wont work and my odometer doesnt work but ive replaced my cluster and both vss on the trans an im still having the problem
lockMAX is offline   Send a private message to lockMAX Find more posts by lockMAX Add lockMAX to Your Friends list Reply With Quote top
Old 12-22-2011, 01:28 PM   #15
Premier Member
my6thgen.org Profile Info.
 
DAlastDON's Avatar
 
Join Date: Feb 2010
Official Member #: 89
Last Online: 02-12-2018 02:56 PM
Location: USA
Posts: 1,224

Reputation Level: 44
DAlastDON is a jewel in the roughDAlastDON is a jewel in the roughDAlastDON is a jewel in the roughDAlastDON is a jewel in the rough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%

My Awards:
Member of the Month (M.O.T.M)  


/ Point Value: 10

Banner of The Month  


/ Point Value: 10

Default Re: How to Install VSS Sensor

The ABS sensors are the primary source for the vehicle speed. The one in the transmission is the secondary speed sensor. The car senses an issue with the primary speed sensors then falls back on the secondary speed sensor in the transmission. Hence why the ABS lights come on after driving then the speedometer starts working.
__________________
Click the image to open in full size.

Inside Peanutbutter Outside Jelly
DAlastDON is offline   Send a private message to DAlastDON Find more posts by DAlastDON Add DAlastDON to Your Friends list Reply With Quote top
Old 07-07-2012, 10:09 PM   #16
Newbie
my6thgen.org Profile Info.
 
Blaquebarry's Avatar
 
Join Date: Jul 2011
Official Member #: 2653
Last Online: 01-05-2015 06:36 AM
Location: Overland Park, Kansas
Posts: 10

Reputation Level: 0
Blaquebarry is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: How to Install VSS Sensor

Did you ever figure out what was wrong with your speedometer? I am having the same problem my service engine light is on, speedometer does not work, mileage stays the same, and the cruise control doesnt work? I had new transmission put in last year and it still isnt working? I was told that my cluster would have to be sent to Nissan to get fixed? Could any one help?

Last edited by Blaquebarry; 07-07-2012 at 10:11 PM. Reason: grammar
Blaquebarry is offline   Send a private message to Blaquebarry Find more posts by Blaquebarry Add Blaquebarry to Your Friends list Reply With Quote top
Old 07-08-2012, 12:57 AM   #17
Moderator
Burnt Orange
my6thgen.org Profile Info.
 
BurntOrangeAppeal's Avatar
 
Join Date: Aug 2011
Official Member #: 2887
Last Online: 12-04-2014 04:56 PM
Location: Under the Bridge
Posts: 2,816

Reputation Level: 34
BurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura aboutBurntOrangeAppeal has a spectacular aura about

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: How to Install VSS Sensor

Originally Posted by Blaquebarry View Post
Did you ever figure out what was wrong with your speedometer? I am having the same problem my service engine light is on, speedometer does not work, mileage stays the same, and the cruise control doesnt work? I had new transmission put in last year and it still isnt working? I was told that my cluster would have to be sent to Nissan to get fixed? Could any one help?
I would start with scanning the Max to see what the CEL codes are.
__________________
'04 SE 6MT, Elite.
'01 SE Anniversary.
'97 GXE.
Click the image to open in full size.
Click the image to open in full size.
-=My Build Tread=-
BurntOrangeAppeal is offline   Send a private message to BurntOrangeAppeal Find more posts by BurntOrangeAppeal Add BurntOrangeAppeal to Your Friends list Reply With Quote top
Old 07-08-2012, 01:00 AM   #18
M Towns Finest
my6thgen.org Profile Info.
 
chris72983's Avatar
 
Join Date: Apr 2012
Official Member #: 5140
Last Online: 03-06-2014 09:18 AM
Location: Tha SIP
Posts: 2,237

Reputation Level: 22
chris72983 will become famous soon enoughchris72983 will become famous soon enough

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: How to Install VSS Sensor

Nice write up
__________________
Click the image to open in full size.
chris72983 is offline   Send a private message to chris72983 Find more posts by chris72983 Add chris72983 to Your Friends list Reply With Quote top
Old 10-30-2012, 08:38 PM   #19
Official Member
my6thgen.org Profile Info.
 
dee.signs's Avatar
 
Join Date: May 2011
Official Member #: 2420
Last Online: 05-23-2015 12:29 PM
Location: Columbus oHIGHo
Posts: 274

Reputation Level: 9
dee.signs is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: How to Install VSS Sensor

Sounds as though you might have an open circuit, or a bad wire to me
__________________
Click the image to open in full size.
Nope, Not Shop'd.
dee.signs is offline   Send a private message to dee.signs Find more posts by dee.signs Add dee.signs to Your Friends list Reply With Quote top
Old 12-21-2012, 01:03 AM   #20
Newbie
my6thgen.org Profile Info.
 
Teazy120's Avatar
 
Join Date: Jan 2012
Official Member #: 3996
Last Online: 05-13-2017 06:14 PM
Location: Nashville, TN
Posts: 68

Reputation Level: 8
Teazy120 is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: How to Install VSS Sensor

so i had the code pop up but how would you be able to tell if the sensor is messed or just the wiring in itself? might be a stupid question to ask. im just on a budget and cant afford to replace anything that doesnt need to be replaced.
Teazy120 is offline   Send a private message to Teazy120 Find more posts by Teazy120 Add Teazy120 to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 11:17 AM.