Register My Garage Arcade V.I.P Members List Calendar Mark Forums Read
Go Back   my6thgen.org - Maxima Forum > my6thgen.org - Very Useful Information > How To's & DIY Mods > Suspension, Handling & Brakes

Reply
ExclamationThis thread is more than 150+ days old. If you still feel it is necessary to bump this thread, you have the permission to do so. Please click the checkbox below and post your reply.
 
Thread Tools
Old 12-17-2013, 02:20 PM   Thread Starter #1
Newbie
my6thgen.org Profile Info.
 
mtndewnut's Avatar
 
Join Date: Oct 2013
Official Member #: 14283
Last Online: 12-17-2013 02:27 PM
Posts: 2

Reputation Level: 0
mtndewnut is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Strut Squeak

Ok. Changed my front struts about a month ago due to the wife slamming a pothole and busting one. Install went ok I guess, considering that this was the first time that I had performed this install.

Got it all back together and test drove it and it drove well. (no pulling when driving or braking) But I noticed, at low speed, when the front suspension would move slightly ( like a small road imperfection or when backing out of the driveway) there is a very noticible squeaking noise. (from both sides) and it's a rubber kinda squeak. Last week I changed the strut mounts... thinking that those were the problem. Nope....still has the exact same squeak. No other problems, just the noise.

Oh.. and just to clarify .... I replaced just the strut ..... not the entire strut assemby

Any ideas?

Last edited by mtndewnut; 12-17-2013 at 02:22 PM.
mtndewnut is offline   Send a private message to mtndewnut Find more posts by mtndewnut Add mtndewnut to Your Friends list Reply With Quote top
Old 12-17-2013, 05:49 PM   #2
Official Member
my6thgen.org Profile Info.
 
Terrentius's Avatar
 
Join Date: Oct 2013
Official Member #: 14402
Last Online: 03-02-2016 10:47 PM
Location: New Brunswick, Canada
Posts: 115

Reputation Level: 6
Terrentius is an unknown quantity at this point

Participation Level: 0%
Activity: 0% Activity: 0% Activity: 0%
Default Re: Strut Squeak

This does not clarify:

"...to clarify .... I replaced just the strut ..... not the entire strut assemby."

What does the entire strut assembly mean to you?
Terrentius is offline   Send a private message to Terrentius Find more posts by Terrentius Add Terrentius to Your Friends list Reply With Quote top
Reply


Currently Active Users Viewing This Thread: 1 (0 Members And 1 Guests)
 
Thread Tools


All times are GMT -4. The time now is 06:59 AM.